Wislink LoRa RAK2243 Ver A configuration problem

Hello,
I have a RAK2245 Pi-Hat Board, and I’m having a problem while configuring it. I downloaded its respective firmware and I exactly followied the guidlines step by step.

However, when I reach the “Configure WiFi” step, after setting the SSID and password the putty discounnects and a message “software caused network abort” appears and then the system goes offline and it doesn’t appear again until I reflash the firmware again into the sd card.

I would appreciate your help and feedback.

The gateway can also be connected via a wired network. The default gateway IP is 192.168.10.10.
If wifi cannot be connected, We need to log in to the gateway through a wired network to find the problem.

Thanks for your reply, I tried to connect the gateway to the router using wired network. However, the problem isn’t solved. I tried to change the timezone, but it didn’t change. Also the reboot problem isn’t solved. I uploaded a screen capture of the configuration steps and the problem Im facing when I make reboot.
I would appreciate your help and feedback.

When the problem arises, are you able to log in to the Raspberry Pi using wired network?
The IP address of the wired connection of the pc needs to be configured to 192.168.10.x.

If you can log in to the Raspberry Pi via a wired network, please send me the contents of the following two files.
/etc/dhcpcd.conf
/etc/wpa_supplicant/wpa_supplicant.conf

1 This is the etc/dhcpcd.conf file

2 and this is the second file.

The file name is /etc/dhcpcd.conf, not /etc/dhcpcd.config


================================================================

2019-08-16%2009%3A43%3A20

Which option did you choose? Is "3 Modify SSID and pwd for AP Mode" or "4 Add New SSID for Client"?

The gateway defaults to AP mode,  similar to a wifi router, the gateway's ssid is Rakwireless_xxx, and your computer can connect to the gateway via wifi.

If you choose "3 Modify SSID and pwd for AP Mode" to modify the ssid and password, and restart the gateway, then your pc must re-select the wifi network, ssid is what you have just modified.

If you choose "4 Add New SSID for Client", it means you have a wifi router and you want the gateway to join your wifi router.

If you want the gateway to connect to a wifi router, you need to select "2 Enalbe Client Mode/Disable AP Mode" and then select "4 Add New SSID for Client".

I want the gateway to join my wifi router. I choose the 2nd option then the 4th one. In the forth option I set the SSID for my router and the password of the wifi. After that, I try to reboot the gateway using the “sudo reboot” command but the connection is terminated and a message “Software cause connection abort” appears.

If you succeed, you will see the following in the file /etc/wpa_supplicant/wpa_supplicant.conf
2019-08-16%2016%3A04%3A12

Is the problem still there?
Can you log in to the Raspberry Pi via a wired connection?
Execute the following commands and send me a screenshot, My email address is [email protected].
1.cat /usr/local/rak/ap/create_ap.conf
2.gateway-version
3.cat /usr/local/rak/gateway-config-info.json
4.ifconfig wlan0