Connect iTracker8211 with AT commands to cellular network fails

Dear community,
I have big problems with connecting the iTracker8211 to cellular network. Spent many days trying to send AT commands, but never get any response, quite frustrating :-/

Setup :

Issue:

I use the RUI_Platform_Firmware_GCC firmware and flashed it to the iTracker.
When sending AT commands (like AT+COPS=?) I do not get any response.
Only the command ATI gives me response:

Quectel
BC95-G
Revision:BC95GJBR01A04

I have the feeling, that the BG95-G modem is not correctly setup/initialized. the GSM_init() looks quite different than for the BG96 or M35. Maybe here is somesing missing ?

What is the needed prozess to setup the BG95-G correctly ?

Has anyone any idea ?

thanks in advance,
cheers, tobias

This is the latest official firmware:

https://downloads.rakwireless.com/Cellular/RAK8211/Firmware/

1 Like

I also tried the latest official firmware you mentioned. And acctually the debbuging-output looks like it is also generated from the https://github.com/RAKWireless/RUI_Platform_Firmware_GCC.
Sending AT commands to the firmware from https://downloads.rakwireless.com/Cellular/RAK8211/Firmware/ just does not output anything (even not ATI). This was with the https://github.com/RAKWireless/RUI_Platform_Firmware_GCC at the beginning the same, until I added:

NRF_LOG_INFO("%s\r\n",rsp);

after line 222:


I really spent a lot of time now to get the iTracker running (and tried all possibilities ):

  • offizial firmware (but even if it would work I could not customize it )

  • online RUI compiler (does not support 8211 )


    If I select the 8212 I get crazy values from my sensors. But also in the 8212 would be the BG96 (and not the BC95-G)!

  • The RUI_Platform_Firmware_GCC (looks until now the most promising). But still does not get any response from itracker_function.communicate_response(rsp, 500, 500 * 60, GSM_TYPE_CHAR); from any AT command (except ATI).

Are there any RAK developers/RAK Stuff Memebers/etc here, which can please tell me how I can get the iTracker8211 working ?

Having a known good firmware that you can communicate with is a good start …

This may be of interest:

https://www.espruino.com/RAK8211

@nmcc thanks for your hint, but as I develop on linux and come from C/C++ I do not see, why I should develop an embedded system with JS/Espruino.

But why does RAK wireless offer firmware for their boards, where the most important part (the cellular connection) is not working at all.
I am still pretty sure that the official firmware for the iTracker8211 is generated by the https://github.com/RAKWireless/RUI_Platform_Firmware_GCC.

Does anyone here has deep understanding of the iTracker RUI functions:

uint32_t (*communicate_send)(uint8_t *cmd);
uint32_t (*communicate_response)(uint8_t *rsp, uint32_t len, uint32_t timeout,GSM_RECEIVE_TYPE type);	

which point to:

Gsm_print:

and Gsm_WaitRspOK

what could be the reason why I do not get responses to my AT commands ?
I already tried with bigger timeout and bigger len

I also tried to use the Gsm_print and Gsm_WaitRspOK directly (with a huge timeout), but still do not get response on AT commands

 Gsm_print(cmd);
 memset(rsp, 0, 1024);
 Gsm_WaitRspOK(rsp, 30000, true);
 vTaskDelay(300);
 NRF_LOG_INFO("++:\r\n %s\r\n",rsp);

Any ideas ?

Because you could create a small bit of firmware to check if your board is OK and, if it is OK, along the way have an eureka moment about your current situation.

By your own admission, you’ve been working on this for a few days, a change of perspective may help.

Alternatively, write the smallest possible program that doesn’t use the radio(s) at all, just to get your debug output working - perhaps just a simple echo?

ahh… maybe there are missunderstandings.
I can print debug statements. and I can also read the sensor values.
I have a running system (like I descibed above) just the modem (quectel BC95-g) does not answer on my AT commands. But this is the most important part form me, to have a cellular connection