Connecting to RAK 7204 with Mac

Issue: Instructions given to interface with 7204 using Windows, not Mac

Setup:

Server:

Details: I am following these instructions to get my RAK7204 on the Helium network. https://dev.to/makahernandez/connect-a-rak7204-to-helium-and-forward-its-data-to-ubidots-55ch.
I have a Mac and when I get to the instructions that refer to this link (https://docs.rakwireless.com/Product-Categories/WisNode/RAK7204/Quickstart/#interfacing-with-the-rak7204-wisnode-sense-home), I don’t know how to connect with a Mac. The instructions are only for Windows. Any links on how to get my RAK 7204 up and running on Helium network with a Mac?

Hello @LeeBee,

Rak Serial Port is a tool that allows sending commands to the device via serial ports in an intuitive way. However, there are different options available for this on Mac. The one I can recommend is CoolTerm.

For more information about the AT commands, refer to this manual.

I hope this helps!

If you need a CoolTerm tutorial, check out https://learn.sparkfun.com/tutorials/terminal-basics/coolterm-windows-mac-linux

If you are a Terminal user:

screen /dev/cu-usbXXXXX 115200

will do the job nicely - it’s what I use when I just need to monitor what a module is doing. Replace the

cu.usbXXXXX

with the name that appears when you plug it in - ls /dev/cu* will list devices plugged in.

Now we have the new DFU serial tool, I only boot my Windows machine when I need to use Atmel Studio!

2 Likes

I’m in the same boat (using a Mac) and these tips were helpful. However, I am only able to see the output from the device in the terminal. When I type an AT command (at+version) and hit enter it does not return anything. Any suggestions?

Thanks.

If you are using coolterm with macOS, ensure that you have the right serial port and comm settings.

image

And on the ‘Enter Key Emulation’, you should select CR+LF

image

you should see something like this.

Thanks @carlrowan. I double checked my settings and they match what you describe. However when I send an AT command there is just no response. When I push a button I see the output.! Appreciate any tips.
Screen Shot 2020-10-29 at 9.37.03 AM|690x477

I’m normally using this for RAK811/RAK4200/RAK4260 - I’ve got my RAK7204 from the kitchen but its battery is flat which is a bit sad after only 14,035 uplinks, so I’ll finagle a replacement and see what happens.

OK, got a new battery wired in. And for some reason, it had wiped it’s settings, but that was a quick fix.

@carlrowan did a demo with a RAK811, presumably a WisDuino, which has a CH340G USB to serial chip.

The RAK7204 uses a CP2102 chip so you’ll need to install the driver for that before you can access it - on my iMac it shows up as SLAB_USBtoUART.

I should have mentioned I’m using a RAK7201 (LoraWAN button) and was hopeful it would be the same as 7204. I tried the driver you suggested and holding down button one that someone suggested unlocks the serial port. I now get a response from the device, but it is simply:
at+version
AT Command ERROR

I also looked at drivers for the CH340G, but read that:
Do not install if you have the current macOS Mojave 10.14 or later. macOS Mojave 10.14 (released in October 2018) includes a CH34x driver by Apple. If both Apple’s and the OEM driver are installed, they will create conflicting non-functional serial ports. Steps 1 to 3 below can be useful to remove the conflicting OEM drivers.

No sensors, only buttons, different serial chip and a part number I’ve not seen - is this the RAK612?

Where are steps 1 to 3 below?

It looks the same as the RAK612, but but labeled as RAK7201 on the back and is on 915Mhz. Got it here: https://www.amazon.com/New-LoRa-RAKWireless-7201-Programmable/dp/B084CZ9CY9

missing instructions are from here:

Thanks again for the help. May end up just having to find a windows machine somewhere.

Hei @whereisseanm, @nmcc,

FYI, the RAK7201 button is not the same as either RAK7204 or RAK612, different in both hardware and firmware.

Regards
Vladislav

Thanks @Hobo. Do you know what chipset it uses for serial/usb?

Hei @nmcc,

I believe it is an CH340E.

Regards
Vladislav

Here is the linux log, when RAK7201 is plugged, just for information

Blockquote[ 87.687650] usb 2-2: new full-speed USB device number 3 using ohci-pci
[ 88.016868] usb 2-2: New USB device found, idVendor=1a86, idProduct=7523, bcdDevice= 2.63
[ 88.016871] usb 2-2: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[ 88.016873] usb 2-2: Product: USB2.0-Serial
[ 89.015785] usbcore: registered new interface driver usbserial_generic
[ 89.016271] usbserial: USB Serial support registered for generic
[ 89.028618] usbcore: registered new interface driver ch341
[ 89.028686] usbserial: USB Serial support registered for ch341-uart
[ 89.028747] ch341 2-2:1.0: ch341-uart converter detected
[ 89.049107] usb 2-2: ch341-uart converter now attached to ttyUSB0

1 Like

I think you mean @whereissean

Hi @whereissean Before use the AT commands, please hold down the number 1 key for a few seconds. All four LEDs will go blue. This is the config mode. Now you can use the AT commands. RAK7201 is based on the RAK4270 module.

@velev Thanks for the tip. I read this somewhere and tried holding the key 1, but what happens for me is that the light next to button 4 turns red (instead of all buttons blue). When attached to serial console the message I see is lowpower mode set to either 0 or 1, so it seems that my device buttons are mapped differently. Any other ideas for how to put it in config mode?

@alnunez Thanks for the linux idea. Actually I do have a few raspberry pi laying around somewhere, so that may be the next thing I try…stupid Mac. :wink: