Multicast Downlink Problem - RAK3172


I have a RAK3172 module working on Class C. I created a multicast group and added it to the device via the ‘AT+ADDMULC’ command, passing the activation keys found in the created multicast group tab (Multicast Address, Multicast NwkSKey, Multicast AppSKey, etc.). I can view the groups added to the device via ‘AT+LSTMULC’ normally. The problem is that, when I downlink the topic provided by the gateway (which is like ‘mcast_group/{{mcast_ID}}/tx’) and replace the ID value with the multicast group ID, it doesn’t seem like the device is receiving any information.

I’m using MQTT Explorer to publish on the multicast topic. Is there anything I’m missing or forgot to configure before?

Welcome to RAK forum @matheus ,

I am not sure how you setup your multicast group.

Please refer on this document to get the full mqtt publish command. This shows both illustration for class B and class C.

Multicast Class B and C.pdf (1.8 MB)

1 Like

Hi @carlrowan
Thanks for your reply! I’ve tried this and worked sucessfully! I thought the error was on the multicast group either, but my guess is that JSON downlink needs to be exactly like that, including the ‘multicastGroupID’ field. It’s kinda frustrating, because you can’t found anything about this nowhere, at least, i didn’t found…

Hi @matheus ,

I will add this to our knowledge hub so everyone can have access. I missed to add this when I created the class B guide.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.