Rak 7204 sensor

I try to connect the Rak 7204 sensor to TTN gateway but it does not activate. It only sends the sensor data when push through the Rak Serial Tool but not to the gateway. How can I fix this does anyone have any clue?

Welcome to RAK forum @parajuliindu ,

When you say not activate, it doesn’t have a successful join to TTN?

Can you confirm if the configuration is correct as well as like the EUI and root keys? Also can you check the Frequency band you use? It can also be RF related like the antenna connection, too far from the gateway, etc.

Everything is correct but it’s not joining…I have tried it several time now it’s been more than a month but no successful. I don’t know what can I do here. EUI, root keys and RF all are correct. It’s an indoor sensor. Can you please help me.

Does the Frequency Band match on TTN, Gateway and RAK7204? Also if you are using US915, are using the channels?

It will be helpful as well if you have another end-device that you can use to troubleshoot the issue. If you have working device that connects to TTN using the same gateway, then we can focus on the device.

No, I have 2 Rak7204 sensor but both of those having connection issue.Maybe I have done some error while activating Not sure…I am in Australia so I use AU915. Is there any help I can take or anyone I can contact?

I am trying to help you @parajuliindu :slight_smile:

Let’s try to check each components - LNS (which is TTN), Gateway and the Device.

It is very common issue that the frequency band set on either of these three is not the same. That’s the reason I have those questions. Maybe if you can share the settings of the Gateway and Device in TTN that can be helpful to verify. Also the gateway should be configured in the right frequency as well.

My idea here is let’s assure first that we have a working network then we can check the RAK7204 after validating we have establish there is no issue or mismatch on configuration in the network side.

Just a side note TTN is using subband 2 for AU915. Check that the subbands are configured correct in both the RAK7204 and the gateway.

1 Like

Now the sensor is connected but when I try to send the at+send=lora: command from Rak serial port tool it throws “error 80” what could be the reason?

Hi @parajuliindu ,

What is the commands you sent before you got that error aside on at+send command? Also what is the interval of your commands sent? Like did you send it each second? It ccould be that there is still process on-going before you send another command.

Thank you for your reply Carl. I have set the interval time as 5 sec. Also wants to know about the Rak7204 firmware version and Where can I find the documentation for it to see what changes have been made so that I can proceed with my setup. Thank you

Hi @parajuliindu ,

You can find the changes on firmware here - https://downloads.rakwireless.com/#LoRa/RAK7204/Firmware/

With regards to your error, 5 seconds is too fast. If you make this longer, the error will likely be gone.

Thank you for your reply. Also the difference in V3.0.0.9.H and V3.0.0.9.L is for different frequency ranges or it’s for same? Sorry, I am just learning lorawan so have multiple questions.

Hello @parajuliindu ,
The H and L separation in this case is for High and Low Band (LoRaWAN Band).
The separation is:
H-High Band support Region : US915 / AU915 / AS923 / KR920
M-Medium Band Support : EU868 / RU864 / IN865
L-Low Band Support: CN470 / EU433

In this case, we do not have M versions but the Medium Band Support is included in the H version.

Thank you for your reply. I don’t get any updates in the gateway or application when I send through at+send=lora:1:1234578 command from Rak serial port tool. I have tried changing the interval as well as suggested but no luck.

Hello RAKwireless,
Just want to ask how can I update the device Eui in rak7204 sensor. Also when I push the at command from the Rak serial port tool it doesn’t throw any reply just shows the command in green color. Actually, I am doing research in the lorawan IOT devices where I am analysing the users mistakes if they put the default dev eui in the sensor for example if the users by mistake put (default dev eui as 000000000). Can I change the dev eui to default as 00000000 just to analyse for research purpose. Please provide me with solutions. Thank you

Hello @parajuliindu ,

You need to use
Note that you can not use 00000000 first because you would need to use the correct format for the dev eui, meaning you would need to use 8bit(16 symbols ) and the zeros are only 8 (should be 16).
Also, you can not put all zeros (0000000000000000), but you can use 0000000000000001 .

More on the dev eui you can find here: LoRa best practices Provisioning for Maximum Compatibility Dev EUI | DEVELOPER PORTAL


Also wants to know what is App Eui…What would be the App EUi of Rak sensor is it the one provided on the device itself or we generate it?

App EUI is coming with the device, you can also set it up as well.
This is the command

also you can find all at commands that you can use with this device here: RAK7204 AT Command Manual | RAKwireless Documentation Center

What is App EUI: what is app eui lorawan - Google Suche

Hello RAKwireless team,
I am using the Rak serial port tool version 1.2.1 but when i try to send the at command all it does it pushes the command and does not show any outcomes just shows the command in green. Why does it do that? Please suggest how I able to fix this? Looking forward to your reply. Thank you

Hello @parajuliindu ,

Is the battery connected to the device while you are trying to access it on Serial Port?