RAK10701 messed up!

Hi

This is in relation with that thread RAK10701-L Field Tester TP Init Failed I have exact same problem on my RAK10701 mapper.
By mistake I updated it with Wistoolbox but not being careful it updated the RUI3 from version 3.5 to 4 with standard fw. I then flashed the specific fw for RAK10701 so now screen goes on again but it displays straight the “TP Init Failed” message at begin.
I guess I need to downgrade RUI3 to latest version compatible with RAK10701 specific fw but can’t find the info anywhere. Does someone know if I can safely downgrade RUI3 ? and which version I should downgrade to ?

Thanks

Vincèn

Hi @vincen ,

I am not sure if the TP Init is related to the version of RUI3 that you have. I tried uploading a standard RAK4630 FW then recompile/reupload the actual RAK10701 source code from here. I do not see any error. It works the same.

Maybe you can try to upload the actual source as well and see if the TP Init failed will disappear.

Hi @carlrowan

Thanks for your message and sorry for confusion but the TP init error started to show up just after I did the wrong update !
I have uploaded the proper code from your link but still the same. Don’t I need to upgrade the RUI3 in it ? I’m quite sure it’s the problem. Is it safe to downgrade RUI3 ?

Thanks

Hi @vincen ,

The source code link I shared must be compiled using the latest RUI3.

The TP Init Fail will only show if the LCD can’t be read.

image

There is no need to downgrade to fix the issue.

Will you be able to track the RUI3 versions you jump on?

In case you want to explore, these are the different version of released RUI3 FW.