RAK10701 won't boot after firmware update

Hi Folks,

Need your support, received my RAK10701 LoRaWan fieldtester yesterday and as per procedure upgraded the firmware as the mobile app suggest so. However, it won’t turn on anymore. While upgrading it was connected to a power supply.

Any suggestions? I only used it for 10 minutes…


to further complete the issue, below the content of the JSON after trying it again, now using a MacBook

{“system”:{“wisToolBoxVersion”:“1.3.1”,“systemVersion”:“macOS 12.6”,“os”:“darwin”},“deviceInfo”:{“connectedAt”:“Sat Jan 28 2023 17:04:23 GMT+0100 (Central European Standard Time)”,“firmwareVersion”:“rak4630_RUI_3.5.3_RAK4631”,“modelName”:“WisBlock LPWAN Module for LoRaWAN”,“atVersion”:"",“modelID”:“rak4630”,“serialNumber”:“AT not support.”},“dfuInfo”:{“startDFU”:“Sat Jan 28 2023 17:05:42 GMT+0100 (Central European Standard Time)”,“targetFirmwareVersion”:“rak4630_RUI_3.5.3_RAK4631”,“BaundRate”:“115200”,“endDFU”:“Sat Jan 28 2023 17:05:45 GMT+0100 (Central European Standard Time)”,“upgradeProcessInfo”:[{“processStatus”:“SWITCH_DFU_MODE”,“timestamp”:“Sat Jan 28 2023 17:05:45 GMT+0100 (Central European Standard Time)”}],“upgradeStatus”:“FAILED”,“failReason”:"{“code”:258,“message”:“Error message for known response code from DFU target: Opcode unknown or not supported.”}"}}

Welcome back to RAK forum @rjwelling ,

Can you please confirm if you use this firmware?

Hi Carlrowan, thanks for your prompt reply. I used the (Android) Mobile App to update the fieldtester to only find out later that there’s very specific firmware for this device. So I guess I crashed it, are there options to (factory) restore it?

tried to apply the correct firmware using my Fedora Linux workstation with the DFU results in the above.

Hi @rjwelling ,

I am not sure what firmware you upload via Android App (also what app is that)?

The RAK DFU Tool doesn’t work on RAK10701. It only works on old modules based on RUI V2. RAK10701 uses RUI3 now.

You need to use WisToolBox. We have a guide here.

Hi carlrowan, I tried using the wistoolbox on a Mac yesterday and today using a Ubuntu machine. Results are the same, see below screenshot that shows the weird display.

pretty weird name for this device.

replying to the question about the Android app, I’m referring to the WisToolBox App, the official one from RAK Wireless

Hi @rjwelling ,

Based on the sequence you did, you use WisToolBox to update the firmware but likely you upload the baseline RUI3 firmware and not the one specific for RAK10701 (we are improving this side of firmware name).

On your WisToolBox desktop, it shows that the RAK4630 is not detected via AT command.

I have some questions:

  1. When you uploaded the firmware via WisToolBox App previously, was it successful?
  2. Can you still detect the device via WisToolBox App? It will look like RAK.xxxxxx (mine is RAK.059B63). If not, ensure that the Bluetooth and GPS is on. Then you can press the reset button on the right side of the USB connector of the device using a small screw driver or pointed tweezer while the WisToolBox is searching for device/s.
  3. When you attempted using the WisToolBox Desktop, can you please confirm that the selected port is correct (if there are multiple ports).
  4. Have you charged the device before doing any connection test? Maybe at least 1 hour charging. Attempting to connect via bluetooth while USB cable is connected should be fine.

With regards to the suspicion of bricked module inside, there is no way to recover it unless we use external tools like jlink or rakdap1. However, before using any external tools, I will suggest to disconnect the battery and put it back again and see if AT commands will be detected by WisToolBox.

Hi Carl, allow me to answer the questions in the same order as stated;

0:) my very first attempt to update the firmware was done by using the WisToolBox Android App and there things went wrong.
1/2:) twofold, went wrong with Mobile WisToolBox app and I can’t find the device using Bluetooth (BLE) when pressing the reset button.
3) the port /dev/ttyACM0 is the correct one and using the desktop version of the WisToolbox it’s able to find it but trying to flash it fails after about 10 sec.
4) I left the device charging for a full night before using it for the first time as per manual. I will disconnect the battery (haven’t tried that yet… due to warranty so if you’re OK I’m happy to do so.

I will keep you posted.

Carl, tried everything you suggested so I guess we can classified it as “bricked”
To add, would it make sense to replace the RAK4630 with a new one and flash it with the proper firmware?


Hi @rjwelling ,

We can say the device is bricked but the PC still detects it as a Serial device since it shows /dev/ttyACM0. There is a very good chance that it can still be revive by using Jlink or RAKDAP1.

However, if you do not have these external hw tools, replacing the RAK4630 and uploading the RAK10701 firmware will surely make your RAK10701 device working again.

super, let me order a RAK4630. will keep you posted. I got all the right tools & antistatic to replace it.

1 Like

Btw @rjwelling , please order RAK4631-R WisBlock Core. The RAK4630 on RAK10701 uses RUI3 firmware.

good news, with replacing the bricked module I’m online again.

A thing to consider: don’t try flash the firmware with a virtual machine using (USB) resources from it’s host. That makes it failing almost immediately.

1 Like

I believe I have the same issue where I uploaded the incorrect firmware through the app. Where can I download the RAK 10701 firmware?

I have found the correct firmware here: RAK10701-P Field Tester for LoRaWAN Pro Datasheet | RAKwireless Documentation Center

I also encountered the same problem, thank you very much for your topic