RAK2013: ./active_lte_module.sh: I/O error

Issue: I can’t talk to the modem at all. sudo minicom -D /dev/ttyAMA0 -b 115200 has NO response. I turned local echo on.

Setup: RPi 3B+, RAK 2013 EG95-NA

Details: When I try to run minicom, I get no response. When I try to run ./active_lte_module.sh, I get:

sh: echo: I/O error
sh: echo: I/O error
sh: echo: I/O error
sh: echo: I/O error
sh: echo: I/O error
sh: echo: I/O error
sh: echo: I/O error

I’ve tried running ./rak_script, and some other stuff. Any suggestions?

After that, you need to configure the LTE network operator’s information. Make sure to disable the automatic connection on start-up feature before starting.

Okay, so I’m using the software from:

and following the README on that page. I don’t have the configuration options, Enable LTE Automatic Dial-Up or Disable LTE Automatic Dial-Up.

I’m using my own raspberry pi. All I bought was the RAK 2013 LTE HAT. I must not be opening the serial port successfully because when I get into minicom with:

sudo minicom -D /dev/ttyAMA0 -b 115200 and type “AT” I don’t get any response whatsoever.

This is not my first 2013 I’ve set up. Just the first time I’ve ran into this issue. I must not be opening the serial port successfully.

This is a clean install of Raspbian Stretch. Not the configured OS from RAK.

Anything else from the stock OS running that might be trying to talk to the modem, modemmanager or brltty or whatever?

Can you move the SD card between this and another system and see if the problem follows the hardware or the software?

Check raspiconfig and the pi configuration on the boot volume of the card, there are, various things about the pi UART enable, pin sharing/remapping, BLE conflicts, etc.

Do you perhaps have a console running on the pi UART?

Also since it’s a hardware UART and not a case of USB CDC ACM you could pull the hat off and see what you get on the pi pins, or probe with a scope/logic analyzer while it’s installed.

If you could get bidirectional communication between serial terminal programs on the pi and on a PC with a USB-UART cable plugged into the UART pins on the pi GPIO in place of the hat, that would do a lot to rule out issues outside of the hat.

  1. I will check right now to see if anything is running on the OS that might be trying to talk to the modem. I will check if modemmanager or brltty. What other programs can I check for? Is there a linux command that will show me any open or attempted connections to /dev/ttyAMA0?

  2. This is the only 2013 I have, but I could try moving it to a different RPi. I have more 2013s on the way, but they won’t be here until JULY 9TH, which is way too far away, I need to get this product shipped out.

  3. Can you walk me through this or point me to a guide so I can check everything thoroughly? I will start checking myself and see if there’s anything obvious I can catch.

  4. Again, can you walk me through this or point me to a guide? I’m not much of an electrical person, but I can buy the required tools if it will help in this situation.

  5. Once again, if you can walk me through this or point me to a guide, that would be very helpful.

Obviously, I don’t have a lot of experience troubleshooting UART or GPIO.

Jordan

I figured it out. This 2013 had been configured to use 921600 baud instead of 115200.

sudo minicom -D /dev/ttyAMA0 -b 921600 and everything is working well.

Thanks for all the suggestions.