RAK2013 Minicom ttyAMA0 offline

Issue: Hello all, I have installed the following GitHub (https://github.com/tvelev/RAK2013-Cellular-PiHat) and the blue and green LEDs are on, the red one is flashing. But when I open the minicom (minicom -D /dev/ttyAMA0 -b 115200) ttyAMA0 is shown as offline and I cannot send any AT commands. Any Idea what might be the problem?

Setup: I’m using the Raspberry 3B+ with the RAK2013 WisLink Cellular PiHat (EG95-E)

Hi @Moritz Please use this git https://github.com/RAKWireless/rak2013_for_rpi.

Thank you for the quick response, I tried to run the new GitHub and the installation was successful but when I try pppd call gprs I get:

timeout set to 30 seconds
send (AT^M)
expect (OK)
Script chat -s -v -f /etc/chatscripts/quectel-chat-connect -T mass.at finished (pid 700), status = 0x3
Connect script failed

Could the problem be that I run the wrong OS. I could not find the right one since the link on GitHub doesn’t work.

Here you can find the latest Buster RPi OS. It should work.

Thanks Velve, so I tried to run the script on the new OS (5.4.78-v7+) like you said but I still can’t dial. The Error is the same as I wrote above and my minicom shows my ttyAMA0 as offline. Do you think that their might be a problem with the RAK?

Hello, @Moritz

Can you take a picture of RAK2013 connecting to Raspberry Pi? I want to look at its indicator light.

Hey @ZhuQI, the Red indicator light is flasing (2 Seconds on, 1 Second off) the green and blue ones are on all the time. I hope this helps

Please use the sudo raspi-config command to disable serial port login and activate the serial port.

step 1

step 2

step 3

step 4

I did that and reinstalled the script but there is still no success. The LEDs still flashes in the same way and the ttyAMA0 port is shown offline in the minicom. When I run “sudo pppd call gprs” I get:

abort on (BUSY)

abort on (NO CARRIER)

abort on (NO DIALTONE)

abort on (ERROR)

abort on (NO ANSWER)

timeout set to 30 seconds

send (AT^M)

expect (OK)



Script chat -s -v -f /etc/chatscripts/quectel-chat-connect -T mass.at finished (pid 609), status = 0x3

Connect script failed

The thing I don’t understand that I got it running a few weeks ago.

After completing the above steps, can the at command be executed in minicom?

No, I can’t do anything in the minicom

So if this helps, I also have the RAK2245 and I tried to run it on my raspberry, and everything worked fine. This should mean that the ttyAMA0 UART works fine and is not used by Bluetooth. Also when I try “ls -l /dev” I get this result: serial0 -> ttyAMA0 and serial1 -> ttyS0.

Hi @Moritz Can you try to connect the RAK2013 with the RPi via USB for communication. Following this guide here https://github.com/RAKWireless/quectel-CM-for-rpi and use the provided code.
Please flash fresh Rpi image.

Thanks @velev, I did what is descripted on the GitHub (my OS version is 4.19.108-v7+) but the connection is not shown in ifconfig. Also I can’t see any ttyUSB0 connections in my /dev register, but there is an ppp listed so the installation should have worked (Green and Blue LEDs are on, and the red on is flashing). Do you have any idea what might be the problem?


I am getting the same error (Connect script failed) with a RAK2013 and raspberry pi 4b and RAK2287.

I will try the USB method posted above to see if that works.

The weird thing is I think something is connecting as I got an email from the carrier that my SIM Was activated after I tried it in the RAK2013
Thanks for the help.

Ok, please tell me how it worked.

Thank you for helping.

I tried installing the https://github.com/RAKWireless/quectel-CM-for-rpi on a fresh RPI image. The latest raspbian os images using linux kernel 5.4.x. Therefore ai get the error drivers are not installed. Are there drivers for this version of linux or only 4.19.x?

Using an older Raspbian image with kernel 4.19 got me connected to the Hologram network. I have not been able to use celluar data yet, but ping to over wwan0 is successful.

Thanks phill for the quick update, so this means that after you installt the file you get an wwan0 connection in the ifconfig? Also do you know if it only works with an Hologram SIM?

Yes I got a wwan0 interface.

I will test with another SIM. I’m just not sure what APN to use with my T-Mobile sim.