RAK2013 - Slow download speed & Speed Rates


I currently am using a RPi+Rak2013+Rak2245+Rak PoeHat setup to work on some gateways based on the RAK7243C firmware.

I’ve noticed that the default rate is 115200, which is the rate I used for all the gateways but my 4G/LTE connection seems to be awfully slow, going up to 20-30kbps at best some of the time. Even download a less than 1Mb file using SSH and SFTP can take upwards to a minute due to how low it is.

I also tried the speedtest and the results are not good. This is using a m2m SIM card.

Using other 2 SIM cards from different providers/companies gives me the same results and on different devices.

I see that that in the manual specifications for Europe, the EG95-E model should have around 150Mbps downlink and 50Mbps upload rates but I don’t think I’ve ever seen this speed at any point other than when I was trying the RAK5146 module.

Is it related to the 115200 data rate used as default? I’ve tried using such other rates like 921600 but after the change it doesn’t even connect and I can’t use the minicom either using that rate.

Is there any way to check this and change it accordingly? Am I stuck using the 115200 data rate? This means I can’t really send big updates remotely to my devices because they are not able to download more than 10Mbs in a sitting without the connection being interrupted or stalled due to the low speeds.

Appreciate any help.