RAK2247 SPI + USB mPCIe x86 gateway

I want to set up the RAK2247 SPI + USB with mPCIe interface into an x86 system. From all the examples a RPi or similar SBC is being used. Has anyone tried using the RAK2247 or RAK833 in an x86 system?

I am trying to set up a simple PoC, two x86 systems and have one receive data while one transmits. I have on my system Ubuntu 1604 kernel 4.4, lsusb shows me the FTDI device.

Bus 001 Device 002: ID 0403:6010 Future Technology Devices International, Ltd FT2232C Dual USB-UART/FIFO IC

[ 9.578054] usb 1-5: FTDI USB Serial Device converter now attached to ttyUSB0
[ 9.583850] usb 1-5: FTDI USB Serial Device converter now attached to ttyUSB1

I can access the serial port but in the documentation there’s no reference to the communication protocol (baud rate, flow control, etc). There are no command set as well.

Has anyone else tried something similar to this? Will the command set for RAK833/RAK2247 be published? Is what I am trying to accomplish feasible with this product?

Hi Henry,

I’m writting a document to show how to use RAK2247 on X86 Linux PC, please wait for my news, i’ll send it to you today.

https://downloads.rakwireless.com/en/LoRa/RAK2247-Mini-PCIe/Application-Notes/

I i’ve bought a RAK833 plus usb board, and I’ve followed the instructions on the pdf on: https://downloads.rakwireless.com/en/LoRa/RAK2247-Mini-PCIe/Application-Notes/. I am using Ubuntu.

In the end while trying to run the lora_pkt_fwd there is an error saying:

ERROR: [main] failed to start the concentrator

Can you please help?

Hello @ingkarlgauss
Can you, please, post the whole log?
You followed this guide RAK2247x86LinuxPC , right?

Regards
Todor Velev

@ingkarlgauss
2019-09-02%2016%3A04%3A26

Please confirm that it is in the rak2247 directory.

Thanks for your reply, in the step 5, you have an error in the PDF. In the document you’ve written:

cp …/set_dui.sh packet_forwarder/lora_pkt_fwd

and it should be read (with an e)

cp …/set_eui.sh packet_forwarder/lora_pkt_fwd

could you please send me a private email to check some questions?

Oh, yes, this is an written error. It should be ‘e’ not ‘d’. We’ll modify immediately.
Thank you very much!

@ingkarlgauss
My email: [email protected]

Following updated guide, I am able to install scripts.

However, upon executing lora_pkt_fwd, I am receiving errors:

ERROR: Failed to load fw 1
ERROR: Version of calibration firmware not expected, actual:0 expected:2
ERROR: [main] failed to start the concentrator

Can anyone advise as to the issue?

RAK2247 has two kinds of hardware, although they are both mPCIe interface. What’s your RAK2247 module? SPI or USB?

Only the USB one can be used on X86 Linux PC now, and it need a mPCIe2USB convert boart as the following picture shows:

Figure 1: RAK2247 to a PCIe-to-USB board

I have the RAK2247 installed into our system, which has mPCIe interface with only USB 3.0 signalling. When calling lsusb I am able to see the UART FTDI device.

Do you believe this to be a HW related issue?

Can you send your screenshots?

Messages when running ./lora_pkt_fwd: https://pastebin.com/tTgeQGpL

lsusb seen below:
image

I need more information before and after this message.
2019-09-12%2008%3A47%3A05

Not too sure what happened there, left device idle. Don’t believe it is related.

[ 11.291848] Adding 1909756k swap on /dev/sda5. Priority:-1 extents:1 across:1909756k SSFS
[ 11.710240] cgroup: new mount options do not match the existing superblock, will be ignored
[ 11.995483] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 7461.694817] igb 0000:01:00.0 enp1s0: igb: enp1s0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX
[ 7461.695019] IPv6: ADDRCONF(NETDEV_CHANGE): enp1s0: link becomes ready
[ 7476.731516] ftdi_sio ttyUSB0: FTDI USB Serial Device converter now disconnected from ttyUSB0
[ 7476.731747] ftdi_sio 1-5:1.0: device disconnected
[email protected]:/opt/ttn-gateway/packet_forwarder/lora_pkt_fwd$

Okay. So, re-installed OS, then followed instructions again. Seems like it is working now. I will need to modify the address from router.us.thethings.network apparently…

ERROR: [up] getaddrinfo on address router.us.thethings.network (PORT 1700) returned Temporary failure in name resolution

On TTN, its recommending ttn-router-us-west. What do I need to do to implement this change?

Hi @hfung
Did you change something in global_conf.json?
The “url” is router.us.thethings.network . ttn-router-us-west is load balancer for this region, not address.

Regards
Todor Velev