RAK3272 ceases to response to AT command after a few days

Hi, I’m using two different types of RAK3272S evaluation board.

one is written ‘8261007X’ and the other is ‘82610049’ with silkscreen.

they all denoted as Rev.C board so there seems no difference but its firmware.

8261007X comes with RUI_4.0.5_RAK3172-E, 82610049 comes with v1.0.4.

what we are currently using is ‘82610049’ board.

after a few days with its powered on state, RAK3272S does not answer against the AT command from host.

Same problem occurs no matter how host UART device used, whether the host MCU is stm32f103c8t6, or raspberry Pi.

more strange thing is, it works good as before once i disconnect power from RAK3272 and power again.

the only way to solve this problem is, to detach the sensor and attach to host again.

i’ve got one suspicious thing ;

  • v1.0.4 firmware seems to has no response problem from its prolonged uptime

is there any problem reported before concerning about its firmware version, v1.0.4?

i know the firmware update is strongly recommended but would it be helpful for RAK3272?

Welcome back to RAK forum @JieunLee ,

Is the issue present on both boards (RUI3 4.0.5 and the legacy v1.0.4)?

For the legacy v1.0.4, it will not be worthwhile to proceed on this version because support on legacy firmware is now halted. The features on legacy firmware are now on RUI3.

For RUI3 4.0.5, does the device have custom firmware or just out of the box firmware? What are the functionalities and setup on this board (AT commands used, interval of sending, unusual current consumption etc.)? We have issue before on device hanging but this should have been solved already in RUI3 version 4.0.5.

1 Like

hi, thank you for your reply.

your support alway helpful.

  1. the error i said has been discovered for the board with legacy v1.0.4 firmware.
  2. not tested on the board with RUI3 4.05 and all of them are just out of the box.
    we’re using lora P2P, it stays receiver mode,
    and every 10 minutes the device receives request messeage. then, the device change its mode to sender mode and sends sensor data.

so the problem could be solved by updating firmware from legacy v1.0.4 to RUI3 4.0.5.

then the firmware downloaded from the website is stable enough?

RUI3 4.0.6 is the latest version so I suggest you use that. That’s version that you’ll get on the screenshot you posted.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.