RAK3272S AT commands No Repsonse and Firmware Upload Failure

I have the RAK 3272S breakout board. It is connected to the laptop via a USB TTL converter based on chip CH340. A COM port is open when the device is connected.

The connection is as follows.

RAK -------- USB Converter (SU109 3.3V)

3.3V -------- VCC
GND -------- GND
UART2-TX -------- RX
UART2-RX -------- TX

Arduino is sat setup and the library is added.

Sending AT command AT+VER=? through the serial gives back nothing. This is applicable for 9600 and 115200 baud rate. I tried Arduino terminal and another terminal tool and they both did not work. Boot0 pulled up or left unused did not make a change.

I tried RAK DFU to upload the firmware in this link the upload timeouts

Machine: Windows 11 Pro.
Arduino IDE ver. 1.8.18 (NOT from google store)

Your help is appreciated.

Welcome to RAK forum @H.mal .

First thing to do is secure that the connection between the RAK3172 UART lines to USB-UART converter.

If you have an old RUI3 firmware that is affected by BOOT issue, you can try to execute AT+RUN or at+run. If nothing happen, then you can try to recover the device using STM32CubeProgrammer. You need to full erase the flash before uploading the latest .hex firmware of RAK3172. You can be guided by the software section of RAK3172 documentation - RAK3172 WisDuo LPWAN Module Datasheet | RAKwireless Documentation Center

I did a continuity test and checked the power, I was able to successfully flash an ESP through the same USB converter but I cannot get an AT reply from the RAK3172 breakout board. The board is not even automatically detected by WisToolBox and cannot read out its EUI.

Erasable flash is not a feasible workaround and to be honest, things should not be this complicated.

Kindly let me know what USB-TTL I can try out other than what you produce, I might be able to find it locally.

Hi @H.mal ,

Securing the USB-UART connection is the first step and it seems the setup you have is ok with the test on ESP32.

The thing I have in mind now is to reupload the .hex firmware using STM32CubeProgrammer (also erasing flash). This can be done using same UART connection you have. It utilizes the UART bootloader of STM32WL chip inside. I find it as an easy way to have direct access on the STM32WL chip without a needed of external debugger/programmer making it simple.

Thank you for clarifying the process, I thought I had to use an ST Link programmer for it.

Connecting VCC GND TX–UART2-TX and RX – UART2-RX.

I followed your recommendation, it works but then connection is lost while running

I tried lowering the baud rate to 9600 but it shows the same error.

Your guidance is appreciated.


I externally powered the RAK module and it no longer disconnects. Will update further!

The new firmware was uploaded successfully using this link STM32CubeProgrammer Guide for RAK Modules | RAKwireless Documentation Center

Now the unit is detected by WizToolBox and responds to AT commands.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.