RAK4200 module discontinued?

Is the RAK4200 module no longer part of the RAK active product line?
I cannot find it on the online shop.

If it is not discontinued, when will it be available again?

Thank you!

HI @mikelebon ,

We do not offer RAK4200 anymore. For new designs, we recommend RAK4270 as an alternative to RAK4200. They are of the same size and supports the same AT commands set but with different LoRa transceiver. RAK4270 is better.

Thank you for the reply.

Just to confirm: the RAK4270 is footprint and pin-compatible with the RAK4200. Correct?

Thank you!

Size and pin layout are the same. Pinouts of critical parts are the same too like power lines, RF and programming pins. For other pin functionalities, you need to double check if it will fit on your application.

RAK4270 pins
RAK4200 pins

If you are using AT commands on RAK4200 with external MCU, you shouldn’t have problems using RAK4270 :ok_hand:

More info can be found here:

1 Like

I have purchased a RAK4200

As I had problems with joining the network I tried the same with a breakout board. Everything was working smoothly there.
→ After observing the differences, I found out, that this module is answering that it is a RAK4270 V3.3.0.14.
OK Board Core:RAK4270
LoRa chip:SX1262
( whereas the module on the breakout board says it is a RAK4200 V3.2.0.15.
How can this be?
How can I find out what it really is? How can I flash the RAK4200 FW into this module?
Best wishes,

I fixed the problem by flashing the latest 4200 FW into it.
Hence it is now reporting a different Chipset :wink:

Now join and send is working, same as on the breakout board.
best wishes,

1 Like

Ok, next module is again with wrong FW for 4270!
Tried to flash it via USART2 → timed out.
Now the module does not respond anymore on USART2.
What can I do now?

Hi @XoverIoT ,

To update the FW, you must use UART1.

I just want to clarify @XoverIoT . Your new and freshly opened RAK4200 replies as RAK4270?

yes, exactly, 2 devices so far. I have 2 more unopend, so I can check these two also.

Hi Carlrowan, thanks for clarification.
I can confirm that I was able to update the firmwar via USART1.

1 Like