RAK4260 Evaluation Board Power supply


What is the voltage input range that can connect to the battery connector?

I’m having difficulties with multiple Tx. RSSI is -100dBm for 2 or 3 times then -45dBm and starting to work.

Tried 3 USB ports.

Connecting a power supply to the Battery connector might solve it?

It’s for a LiPo - there is a LDO to moderate the voltage and a battery charger chip.

Different computers? A 2.1A USB charger?

I have a Tracker RAK7200 and used it’s battery. No improvement. If you remove the USB cable the LED goes off… Then I don’t know the function of the battery.

Only one computer available. How would I connect a charger but still use the USB to input data from the serial port tool?

Looking at the data again on the Mikrotik Gateway:
The eval board tries different frequencies until it finds one. I tried ten times and wrote down which freqs works, but they all work. Just not the first time. That is why I suspect a power issue.

You may want to check the battery is already charged.

Hacking a serial to USb adapter so you can provide separate power is always useful - you need to leave the Tx, Rx and Gnd wires in place and then provide a good 5V on the Vcc.

But the main thing to check is that you have an known good aerial installed firmly - uFl & SMA connectors can cause all sorts of little niggles.

Perhaps try adding a decoupling capacitor 1-10uF to the 3v3 power supply, eg between pins 1&4 of J4. Also take a look at http://www.marvellconsultants.co.uk/LoRaNode

Thank you Nick and Steve for the replies.
The unit does not work with a battery. If you remove the USB cable, it dies. Battery fully charged to 4V (from RAK7200 Tracker). It fits directly to the battery connector. The USB seems to charge the battery when inserted.
I replaced the supplied USB cable with a thicker one. Much better.
Yes I think a larger cap (1-10uF) on Vcc is the solution.

Pity there is no schematic available. This is a development board!!!

Thanks Steve I had a look at your site and will refer to it from now.