RAK4260 & Microchip SDK (Sleep Modes)


I’m using Atmel Studio and ASF to program and test RAK4260. I started to use serial communications, external interrupts, timers, RTC and GPIOs with success. However, I tried to put the device on Backup mode and the current comsumption does not fall. Now, with all GPIOs in 0, the current is ~1.8mA @3.3V. I suppose that the module has more peripherals to deactivate, right?

Hello Ricardo,
Have you deactivated the power of 32M crystal,and the power of RF switch? The power of 32M crystal is controled by PB03 and the power of RF switch is controled by PA28.

Hi, @hairui!

Yes, PB03 and PA28 are forced to zero before I call system_sleep(); . I switch off the usart too.

Hi RicSToz, this is a demo of low power . please FYI. https://github.com/RAKWireless/RAK4260_Low_Power_demo/tree/master

Hi @RicSToz, I had the same experience. Sleep current was around 1.4mA @ 3.3V
I tried another (more expensive and far more accurate) meter and got the same result.

Try shorting out your current meter by touching the probes together and only measure when you know the RAK4260 is sleeping. See if you get a different result.
With this method I measured 2.6uA. Got the same result on my cheap handheld meter and the more expensive meter.

I am using the code from RAK which puts the RAK4260 in Standby mode.

Refer conf_pmm.h

1 Like

While trying to find the problem, I also forced off all the GPIO pins to the RF stage just in case they were not being switched. I found it made no difference, the extra code is not needed and so i removed.

1 Like

I believe the SAMR34 (RAK4260) does not go to Sleep and continues to draw 1.4mA if the current meter is in circuit. Its probably the extra resistance the meter adds to the 3.3volt power line which causes this.

It reliably goes to sleep with 2.6uA if the current meter is shorted and only added to the circuit when the chip is asleep.

I don’t know what is causing this, maybe someone can explain.