RAK4630 compiling and serial not work

Issue: Can not test RAK4631 with baseboard 5005

Dear Sir,

I tried to test the RAK4631 but it can not be tested.
I sent the serial with (at+ver=?) but no response from the board.
I even tried with RAK SERIAL PORT TOOL but no response.
Everything is correct, Port Number etc.
I already tested the things as far as I can find from this forum.
And the attached photos are for reference for the problem that I am facing now.
I tested with some RAK Wisblock RUI example programs in arduino.
I’ve found out that from the error, it said that (“Device is either not in bootloader mode, or using an unsupported bootloader”).
So I re-uploaded the bootloader using from the beegee mentioned (Bootloader Fails to upgrade via BLE - #3 by beegee) but the problem is not solved.
Can someone give me some suggestions about that issue?
It already took me 3 days to solve this one but no progress.

Details:




Best Regards,

Welcome to the forum @kaungsoethar

The content of the INFO_UF2.TXT shows that your RAK4631 has a bootloader based on our Arduino IDE open source BSP, not RUI3.

To use your RAK4631 with RUI3, please follow the guide in Updating RAK4631 to RUI3.

Hi,

I would like to use it with Arduino IDE.
Do i need to update to RUI3 ?

If you want to use RUI3 and Arduino IDE, you have to change the bootloader, then follow our RAK4631-R Quick Start Guide
More information about supported IDE for RUI3 are in the RUI3 Documentation

If you do not want to update the bootloader, you can use the open source version in Arduino IDE.
Just follow our Quick Start Guide to install the correct BSP in Arduino IDE and check out our examples in our WisBlock repo

1 Like

Mr. Beegee,

I got it with thanks.
Now it works well.
you are the best and I really appreciate your time and your help.

Cheers !
Kaung Soe Thar