RAK5010 no longer worging after ppgrading firmware through DFU using BLE

I followed the steps documented here:

Everything worked, I could see the progress of the upload up to 100% and then the device restarted.

After that, the RAK5010 is no longer detected by the computer (no COM port) and it doesn’t appear either when scanning for Bluetooth devices.

What can can I do to recuperate the device?


Hi @antoine ,

I validated the DFU via BLE and it is still working good on my RAK5010.


I exactly followed the steps.

Before you did the DFU BLE upgrade, what is the condition of the device? What is its last state/configuration?

Its a new module that I received recently. I did some testing with AT command and a SIM card. I could validated it connected to the network and was working well. The firmware version said v3.0.0.15

Then, I performed the DFU BLE upgrade.

I am going to try flashing directly with the J-Tag port but I don’t have the hardware yet.

I don’t see what else I could do at this point.

One additional point. I initially tried the upgrade using an iPhone but it wouldn’t connect to the device. I then tried with a Samsung Android phone and that one worked.

I used OpenOCD with a Raspberry PI to flash the device and it is now working again.

1 Like