RAK5146 & RPi 4

I made an SD disk with Rak-Gateway firmware and started the RAK-Gateway system. This board is connected to my TP-Link router via an Ethernet cable. The router address is I see that rak-gateway has addresses and Which way can I access those addresses on my local net? Under which address is openWrt to configure the gateway? I configured LAN and wi-fi connections using gateway-config and found the Chirpstack configuration under port 8080. I tried to access the OpenWRT web interface using the above addresses (port 80) without success. Without having access to the OpenWRT web interface, I can’t fully configure the gateway.

I changed addresses to my local router and now I see all addresses using ping command. I can use the SSH command. I can open the Chirpstack, but still don’t know how to open the Open-Wrt configurtion for the RAK-5146 gateway.

After configuring my gateway using the gateway-config command, I thought the green LED would fire, and I could discover this device, but nothing happened.

Hello @marekpow ,

I would recommend a different approach.
Flash the SD card with plane Raspberry OS (the newest one with CLI only would be perfect) and then when connected to the running RPI use this repo to run the concentrator: GitHub - RAKWireless/rak_common_for_gateway

There is an explanation for using the repo in the README file.

Nikola Semov

Thank you @Nikola

I did do as you said.

There is a problem with authorization for the PostgreSQL database

I expected that the database would be ready to use after installation. The same situation is with the app server

And finally, I can’t open the Chirpstak web interface under the 8080 port. What should I do to resolve this problem?

All Chirpstack databases were created, so what went wrong with the installation?

I installed it on the RPi 4 board.

I see that green LED fires on the gateway board, so I expect that it’s ready to work.

I can access the gateway using SSH.

Hello @marekpow ,

I have just tested with RAK5146 SPI + RPI4 on my side with rak_common_for_gateway

It works just fine. Here is a guide on how to install the script: Quick Start Guide for Raspberry Pi and RAK LPWAN Concentrators | RAKwireless Documentation Center

After you have installed the software you will need to use the “sudo gateway-config” command > 2nd option “Setup RAK Gateway Channel Plan” > 2nd option “Server is ChirpStack” > 1st option “Chirpstack Channel - plan configuration” > Select the channel plan > press ok so you set the SERVER_IP to

Everything should be fine by now and everything is ready to use as installed. If the problem still exists, don’t hesitate to get in touch with us at [email protected]

Nikola Semov

Hello @Nikola

I did it exactly according to the instructions. As you can see, all needed services are up, but the Chirpstack web interface doesn’t work, probably because PostgreSQL has an unexpected problem.
I installed the latest OS version for RPi 4 and the following gateway software.
I have one question. Should WiFi on the gateway work as an AP or client?

If an AP, then is it managed by Open-WRT software? What is the port on which I can handle AP? HTTP via port 80 or HTTP on port 443??

Hello @Nikola

Maybe it is important information, but I have an SPI concentrator, not a USB.

From the Chirpstack documentation:

I found initial_sql.sql and install.sh scripts. They do all installation of PostgreSQL of the Chirpstack.

But when I try to login to the database according to the last line from the screenshot, then I get a message:

PostgreSQL works normally:

So, I have a question: what are the passwords for chirpstack_ns and chirpstack_as?


Installing only gateway software is not enough. I have installed the newest version of RPi OS software on my board:

To achieve a fully operated gateway with the Chirpstack on the board, we need to:

  • change passwords for chirpstack_ns and chirpstack_as users in the PostgreSQL database,
  • switch the user to the root privileges (sudo su)
  • change the DSN in both configuration files, inserting new passwords created above

    . They are located on the following paths: /etc/chirpstack-application-server/chirpstack-application-server.toml and /etc/chirpstack-network-server/chirpstack-network-server.toml.
  • restart both services: /chirpstack-application-server and /chirpstack-network-server

And finally, viola:

I’m glad to hear that you managed to solve the issue.

Nikola Semov

Hello @Nikola

It was a good news. But the bad news is that my gateway floats in the Atlantic Ocean.

I have a brand new RAK-5146 device.
GPS cable is well fixed on the board.
Do you know what might be a problem?

I work on the Chirpstack 4.2.0 and RPi 3B board.

It’s from my brand new RAK5146 gateway:


As you can see, total chaos.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.