RAK7200 node, GPS tracker

First impression with firmware

  • GPS sleep/awake works fine. The at+set_config=lora:send_interval variable will extend due to GPS sensor awake time
  • Batt charge LED is not working
  • The Magnetometer is not send with LPP standard code but as 3 seperate ‘voltage’ sensors:
    Serial port:
    Acceleration(g) of X,Y,Z:
    Gyro(degress/s) of X,Y,Z:
    Magnetometer(uT) of X,Y,Z:

TTN console:
“accelerometer_3”: {
“x”: 0.118,
“y”: 0.036,
“z”: 0.959
“analog_in_10”: 3.9,
“analog_in_11”: 5.1,
“analog_in_8”: 3.99,
“analog_in_9”: 40.2,
“gyrometer_5”: {
“x”: -0.04,
“y”: -1.39,
“z”: -0.12

  • Lora range is terrible with internal antenna. With external antenna it performs a lot better, but… the tracker is not seen by some gateways even within range. It is the same as previous firmware. My TTGO-beam works fine with those gateways. (in Dutch: in de polder geen verbinding met de Almere gateways…)
  • After a restart the serial port tool reports: Please Configurate parameters… and after a while it reports: Configuration OK!
  • Sensor error: LPS22HD not found!, but the temp/baro is indeed removed and not sent. The sensor is still in the boot enviroment.
  • Documentation with regards the AT-commands is not updated.
  • TTN mapper is not updated and Cayenne is not updated with regards GPS on every LORA update (it is received by the gateway. Looks like the GPS LPP protocol is incorrect, corrupted.

anyway thank you for the good work!



Hi Fomi,

Attached the Cayenne data from today RAK7200 with firmware

You can see the port/channel GPS is not always working. In TTNmapper there isn’t any data.

Could it be the bug is back which was solved in



Hi @JeroenKl,

I can’t see the attachment, can you please attach it again?

BTW, we find a bug in the latest firmware too, and we are working on it.
Maybe the issue you met is same with mine.
Let me have a look at the attachment firstly.
Thank you!

1 Like

Hi @JeroenKl,

OK, i receive the attachement now in email.

1 Like

Here are my 25 cents:

  • ABP works. configuring goes sometimes good sometimes bad. I used the RAK serial port tool. Hterm caused many problems.
  • AT responces are erratic, unpredictable, and un-understandable. I get OK and then “AT format error”.
  • Configure transmit interval fails: Whats going wrong?

AT format error.

I see references to TTN mapper. Is there any documentation on TTN mapper integration?

Thank you! @pe1mew

I think these issues are because of the sleep mode.
In this version, we add the sleep mode. By default, after joining successfully, RAK7200 will send sensors’s data then sleep. After some time, RAK7200 will wake up and send sensors’s data then sleep again…, and so on.
When it works in sleep mode, you can not configure it surely.

BTW, there is an error in AT command format. It should be:

I think it is because of the old document. We’ll update it soon.

1 Like

@Fomi Thanks for your answer. It solves the issue of the interval.
It is always more difficult when you are an early-adaptor of something.

Keep-up the good work ! I’ll wait for further versions and updated documentation when they come.

Hi Fomi,

When can we expect the new firmware?
Do you recoginise the other issues as well?



Hi @JeroenKl,

Yes, after testing for 2~3 days, we find an issue about clock.
We’ve fixed it and release a new firmware today.

1 Like

Hi @Fomi,

Thanks for - I can confirm that the device is now sending data correctly to our loraserver.io installation.

One thing I have noticed is that every time I upload the firmware, I have to reconfigure the device with it’s DevEUI. Is there any way to prevent this?

Also, is there a way to write this data from Linux? I try and avoid Windows as a rule, however I do have plenty of existing tools such as the Arduino IDE and Platform.io already installed, so if there’s a way to flash this without having to reboot into Windows that would be great!

Thanks in advance.

@JeroenKl - Are you seeing any GPS traffic from this device on the new firmware (

I’m getting orientation sensor information, but nothing for either GPS or Battery Level.

I’m sorry @proffalken.

About saving the configuration data, it works well in my side. When i update the firmware or restart it, the configuration data are all saved so that i needn’t to configure it again… Can you try again to find if there is still this issue please?

About Linux, do you mean a Linux serial port tool or a Linux version firmware upgrade tool? If you mean the front one, i think there may be some tools in Linux, but if you mean the last one, i’m sorry for that because that upgrade tool only support Windows by now.

@Fomi ignore the comment/post about the settings being saved, it turns out that when the device reboots it says that I need to set the parameters again, however when I run at+get_config=lora:status the keys are there, and after a while the node joins the network.

I can communicate via the serial port with the device using the Arduino IDE, it was flashing the firmware that I was hoping to do from Linux.

Hi @proffalken,

We’ve just tested again to confirm the GPS. Please have a look at the following pictures:

As you see, GPS works well.
Maybe you can use the following AT command to open GPS again, i think it may be closed.

Hi @proffalken,

Yes, i have a plan to do an upgrade tool which can work on Linux, even if i want to made a small hardware tool which only include a MCU to do upgrade and configure especially. :slight_smile:

But now, it only support Windows. Sorry for that.

@Fomi thanks for all the replies and help, I’ll give them a go shortly. No worries on the Linux thing, just saves me time instead of rebooting!

I’ll wait for the linux version to be released! :smiley:

Can’t wait for the new firmware to be released

@Fomi here’s the output when I start up the device on the new firmware:

OK,restart ...

______  ___   _   __  _    _ _          _               
| ___ \/ _ \ | | / / | |  | (_)        | |              
| |_/ / /_\ \| |/ /  | |  | |_ _ __ ___| | ___  ___ ___ 
|    /|  _  ||    \  | |/\| | | '__/ _ \ |/ _ \/ __/ __|
| |\ \| | | || |\  \ \  /\  / | | |  __/ |  __/\__ \__ \
\_| \_\_| |_/\_| \_/  \/  \/|_|_|  \___|_|\___||___/___/
S76G_B version:
Please Configurate parameters...
Configuration OK!
lorasend_interval = 60
MPU9250 Init OK
LPS22HD not found!

Selected LoRaWAN 1.0.2 Region: EU868
Initialization OK,Current work_mode:LoRaWAN, join_mode:OTAA, Class: A
DevEui:<DEV EUI>
OTAA Join Start... 
[LoRa]:Joined Successed!
Start Search Satellite ...
FAIL.The Satellite signal not found!
Battery Voltage = 3.74 V 
Acceleration(g) of X,Y,Z:
Gyro(degress/s) of X,Y,Z:
Magnetometer(uT) of X,Y,Z:

[LoRa]: Send out
[LoRa]: Unconfirm data send OK
Go to Sleep.

and here’s the device setup output:

===============Device Status List================
Board Core:  S76G_B
LoRa chip:  SX1276

Battery Voltage = 3.81 V 

Support Gps:true
Gps Timeout:60 s
No signal with Satellite.

MPU9250 sensor:
Acceleration(g) of X,Y,Z:
Gyro(degress/s) of X,Y,Z:
Magnetometer(uT) of X,Y,Z:

LPS22HD sensor is closed or not found.

===================List End======================

However even when the device is outdoors for a significant period of time, I still don’t get any GPS data from the unit.

I’ve run at+set_config=device:gps:1 as suggested above, but still no results.

Any ideas?

Yes, you need to wait for as it is a bug which was solved in but re-appear in
I’ve got the same issue.

1 Like

I do see following error while bootloading.

Anyone else see this error?