RAK7204 Not able to use

Hi, I just received a RAK 7204 environmental node and is exciting to powered it up

However, after connecting the battery connector to the board, the board only flash a blue LED then nothing happen.

It also cannot be detected by RAK 7258 indoor gateway.

Please advice. TQ!

Hi @ckchun,

Can you please connect RAK7204 with your PC, and get the log output of serial port, then send the log to me?

I follow your suggestion, I boot the RAK7204 with USB and connect it with serial tools. I also press the reset button on the side of the device but nothings shows on the serial tool.

Hi @ckchun,

Is it the correct COM for the connection of RAK7204 and your PC?
If it is correct, i think maybe the firmware or bootloader of your RAK7204 device is not correct. Maybe there are some work fault in our side…
You can please flash the bootloader and the firmware one by one for your RAK7204 according to our document:

The latest bootloader and firmware can be downloaded from here:

Hi Fomi,

I had jumped the VDD and Boot PIN on the device and try connect with ST32 software but I get this error while I try to connect:

“Error: Activating device: KO. Please, verify the boot mode configuration and check the serial port configuration. Reset your device then try again…”

Please advice. TQ!



Hi @ckchun,

Have you jumped the board as this?

If you have, i think maybe you forgot to push the reset button.

Hi Fomi,

I put the jumper as below, I also press the reset but to confirm the reset button is as below?

However, the error is the same

The green jumper seems strange, so i think maybe you can change another jumper and try again.
For this case, we use a jumper to connect VDD with BOOT pin togather.

BTW, that is the reset button.

Hi Fomi,

I changed a few different jumper but the result is the same.

You’d better use a wire to connect the VDD to boot and reset the device to see if the result is different.

Hi @ckchun
Can you please change the micro USB cable? Do you here a new device found sound when plug in the micro USB? Can you check that only this com port is available in device manager?

Hi Velev,

When I plug in the usb cable to the RAK7204, I do hear a new device found sound and it is the inly COM in the device manager.



Im having the same exact issue. Did anyone find a solution?


Hi @Dburtbgi
Sorry for late reply. Did you solve your problem?
If not please describe it.

Todor Velev

Hi everybody,
it seems that nobody solved this problem?
I have the same issue. I have two pieces of RAK7204, I have bought them a month ago. I’m not able to communicate with them with AT commands. Both of them seem dead (?). I can see COM ports with Silicon Labs CP210x USB, I can hear sound that device has been found but that is all. Tried to change USB cables (tons of them). nothing helped. Also tried different serial terminal (Hterm which I use for other LoRa devices) and it also doesn’t help. I did reset devices several times.
So quite frustrating with device which is not cheap.
Have anybody use this device without any problem? How did you solve it?

I tried also different computer.
Then I tried the STM32 Cube Programmer and I have the exact problem as described above:
“Error. Activating device: KO. Please …”.
So came to the point as described above, I also have double checked jumpers. All according description in user guide. Nothing helps. Any idea?

Commonly, you’ll have that issue if you are not on the right boot mode.

To be on the right boot mode, you need to short the pins first then connect the USB cable to PC.
I can’t see any reason why you fail other than the STM32 inside RAK811 is not responding.

Just for sanity check, can you confirm your 3.3v supply is ok? You should have 3.3v across C34/C41.

Hi carlrown, thanks for fast response, I appreciate it.
If I unpack product I would expect that it is in “right boot mode” and it connects so that I can configure it.
I didn’t intend to re flash the firmware but it was the last hope … we are looking for product that are easy to operate, if we want to buy tens or hundreds I can’t imagine to re-flash it piece by piece or have configuration problems.
So, I first expect that I can use your serial port tool, it didn’t work so I went to STM32 tool.
Sure, I have shorted the pins according description:

Reconnected/reset tens of times. Nothing happened.
I’ll check the power supply as you suggested.

“3.3v across C34/C41”, where should I look?

1 Like

I don’t think that RAK7204 is unfunctional, becaouse it sends the join requests and I can see it on GW and also in LoRa aplication server:

finally it works, some reset helped or different cable, or combination, who knows. Now I’m able to set parameters. in serial tool.

1 Like