RAK7204 Unable to flash latest firmware-version

Issue: Was anyone successful in upgrading the firmware of RAK7204 to the latest version (RAK7204_v3.0.0.14.H.R App.bin)?
I have tried it with the “LoraButton Upgrade Tool V1.0” and with the “RAK Device Firmware Upgrade Tool v1.4.exe”. Both of them didn’t work.

The device was in Boot Mode and the boot-jumper was removed. With both tools, I got a timeout error and it’s not possible to upgrade to version

I can only flash firmware-version v3.0.0.10 with the LoRaButton Upgrade tool.


Hello @hasiflo

This is what I did to flash the latest firmware to RAK7204:

I used the jumper to shorten the BOOT and VDD pins like in the documentation:
Opened the STM32 Cube Programmer and flashed the hex file here:
(note: the H and L stand for High and Low frequency)
After the flash, I disconnected the device and removed the jumper.
After that, I connected to the device using the RAK Serial Port Tool and ran the following command to set it in BOOT mode: at+set_config=device:boot
Then, by using the the RAK Device Firmware Upgrade Tool I was able to flash the firmware.

Can you try this and let me know if things went well?

hi @Martin,

thank you for your detailed answer. I was not able to update the sensor with your instructions. But in the end I got the latest firmware flashed.

What did not worked:

  1. I was able to flash your suggested bootloader with the stm32 cube programmer. I could connect correctly, but I was not able to clean the flash → I got a timeout. Flashing the hex file worked well.
  2. Further, I was not able to set the device in boot-mode. I removed the boot-jumper, but I was not able to send or receive any commands through the Serial Port Tool.
  3. As result it wasn’t possible to flash the latest Firmware with the Device Firmware Upgrade Tool.

What worked for me:
I found out, that there is also a boot + firmare binary file in the downloaded folder of the latest firmware. I was able to write this file to the flash with the STM32 Cube Programmer.
After that, the device had the latest firmware and it worked very well with the Serial Port tool.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.