RAK7243 - GPS stop working

Hi,
I have the 7243 + LTE.
It should work for few minutes and than I turned off the ttn-gateway and the lora services for 30min and than back (all that in a loop).
After few hours the GPS stop working. also reboot of the RAK doesn’t help.
I tried to stop ttn-gateway service and run only the lora_pkt_fwd. Got the following messages -

INFO: Disabling GPS mode for concentrator’s counter…
INFO: [down] PULL_ACK received in 0 ms
INFO: host/sx1301 time offset=(1585216968s:535125µs) - drift=374156373µs
INFO: Enabling GPS mode for concentrator’s counter.

INFO: [down] PULL_ACK received in 0 ms
INFO: [down] PULL_ACK received in 0 ms

##### 2020-03-26 10:03:21 GMT #####
### [UPSTREAM] ###
# RF packets received by concentrator: 1
# CRC_OK: 0.00%, CRC_FAIL: 100.00%, NO_CRC: 0.00%
# RF packets forwarded: 0 (0 bytes)
# PUSH_DATA datagrams sent: 0 (0 bytes)
# PUSH_DATA acknowledged: 0.00%
### [DOWNSTREAM] ###
# PULL_DATA sent: 3 (100.00% acknowledged)
# PULL_RESP(onse) datagrams received: 0 (0 bytes)
# RF packets sent to concentrator: 0 (0 bytes)
# TX errors: 0
# BEACON queued: 0
# BEACON sent so far: 0
# BEACON rejected: 0
### [JIT] ###
# SX1301 time (PPS): 2673059
src/jitqueue.c:448:jit_print_queue(): INFO: [jit] queue is empty
### [GPS] ###
# Invalid time reference (age: 1585217001 sec)
# no valid GPS coordinates available yet
##### END #####

also the GPS device is outside, the GPS cable looks ok, turn off and on the i2c from the raspi-config.

Thanks

Build lora_pkt_fwd with DEBUG_GPS and get the messages -
ERROR: NMEA CHECKSUM 58 DOESN’T MATCH VERIFICATION CHECKSUM 42
Warning: invalid NMEA sentence (bad checksum)
ERROR: UBX message is corrupted, checksum failed
Maximum length reached for nmea_checksum

Hi @sagis,

For confirming whether it is a hardware issue, there is a simple way to check:
You can download and flash the latest firmware for RAK7243C (RAK7243 with LTE):
https://downloads.rakwireless.com/en/LoRa/Pilot-Gateway-Pro-RAK7243/Firmware/
and flash it into a new SD card according to this tutorial:

Here is the fully document for RAK7243C:
https://doc.rakwireless.com/rak7243c-lorawan-developer-gateway

Then try again and tell me the result.
Thank you!

Hi @Fomi,

Tried with the latest firmware and also on another HW and saw the same issue - it works for awhile and then stuck. I checked with i2cdetect (expect to find the GPS on 0x42) but it didn’t find anything.
Is there any other device on the I2C bus?
Thanks

What information can "sudo i2cdetect -y 1" display?

2020-03-30 09:25:48

What did you do after using the new firmware? How long does it take to lose GPS information?

Thanks @ZhuQI,

  1. Burn the new image (7243C) and put it in new RAK
  2. Use sudo gateway-config to set - chirpstack, US channels, WiFi(client)
  3. Use Putty to copy my code to the GW
  4. Connect 3 USB cameras
  5. After about 10 min (the ttn-gateway working) check with ‘sudo i2cdetect -y 1’ and saw:
    image

Does this issue occur with new firmware without performing steps 3 and 4?
RAK7243 with LTE version obtains GPS data through the i2c interface.

Hi @ZhuQI,
Without 3 and 4 the same.
uname -a return - Linux rak-gateway 4.19.75-v7+ #1270 SMP Tue Sep 24 18:45:11 BST 2019 armv7l GNU/Linux is it correct?

Use the "gateway-version" command to display detailed information of the gateway firmware.

1.What information can be found using the command cat /boot/config.txt | grep i2c
2.Use the command “ls /dev/i2c-1” to see if the device exists.

  1. image
  2. I made another try - burn the new image again and leave it working so now it is running. When it will stuck again I’ll update

Hi @ZhuQI,

It worked for few hours ok and then I connected the 3 cameras (without capturing images). It worked about 10 hours and stuck.
ls /dev/i2c-1 show that the device exists.
Is it possible to check with scope on the I2C?

According to the test results, I think it is most likely that your cameras are affecting the i2c interface of the Raspberry Pi.

Hi @ZhuQI,

I used echo ‘1-1’ | sudo tee /sys/bus/usb/drivers/usb/unbind to turn off the cameras USBs when the GPS working and it seems better. It worked now for about 6 hours.
So looking forward… my system run on battery so I want the packet forwarder and the Lora server to work in parallel with the cameras. Is it possible to run simple GPS application (I changed the GPS test app to return more data from the GPS) and after that run the packet forwarder (without the GPS) and the cameras in parallel?
I mean is it possible to run all the Lora services without GPS? I saw that the flag “gps”: true, removed from the config file but I can update the code. Will it work?

Thanks

Delete the following two lines in the file /opt/ttn-gateway/packet_forwarder/lora_pkt_fwd/global_conf.json to close lora_pkt_fwd to obtain GPS data.
2020-03-31 16:46:20

in the latest image there is no “gps” key. is it enough to remove the tty path?
image
Thanks

“gps” is an obsolete parameter.
“gps_tty_path” must be removed to disable the gps function of lora_pkt_fwd.