RAK7249 can’t connect after internet lost connection with LTE

Issue: RAK7249 can’t connect back to internet after internet lost connection when using LTE.

Setup: RAK7249 v1.3.5 - Solar powered - LTE as main, and only backhaul.

LoRa® Server: eu1.cloud.thethings.network


Hi everyone, before anything I’d like to say that this is my first post, sorry in advance if there are any mistakes. As usual, I’ve searched the forum looking for any similar problem and found one possible solution here. Sadly, it didn’t fix my problem.

I’ve been using this gateway (7249) for months at my office, worked like a charm, when it was time to deploy it at the field everything went smooth at the beginning, but problems were soon to appear due to the remote location where the gateway is placed. LTE is the only way the gateway has to access internet in this remote location, but the signal is not always good enough, so the signal might go down for several minutes (10 - 20 minutes) and when this happens the gateway loses connection to TTN and WISDM and never comeback online again. The only way to make it work again is to do a reboot or power cycle. This is quite a problem due to the remote location where the gateway is deployed. Some local people help me out to access my gateway (wifi) so I can tweak some configurations and some power cycles, but nothing has worked so far.

I will be able to visit this remote location in the coming weeks, so some help in this matter would be highly appreciated. Thanks so much in advance.

We have been experiencing similar problems with our gateways. Did you ever identify what caused the gateway to not be able to reconnect?

Hi @LasseRegin,

I didn’t find any solution yet. I’m going to upgrade the firmware to the latest version and do some test there next week (hope that works). But just to be sure, I’ll try to run a script on the gateway to reset itself periodically.

If you found the root cause of the problem or any other solution, please let me know. Thanks.

Thanks for letting me know!

We haven’t found the root cause of the problem yet either unfortunately, however the release notes of the latest firmware 1.3.8 seems to have an interesting point:

  • Cellular connection can not be established after reboot sometimes and change EG95-E autoSel change from 0 to 1.

I’m hoping this helps resolving our issue. We are still gonna run a script periodically as well rebooting the gateway if there’s no internet connection (based on pinging

I will let you know if we figure anything out.

Hello @olivos22 @LasseRegin ,

Firmware version 1.3.8 should solve the issue.

Best Regards,
Nikola Semov

1 Like

Thank you @Nikola !

Is it possible to get a description of what was wrong, and how it has been fixed? Would be really appreciated to get an understanding of this issue. For all of us I believe.

Hello @LasseRegin,

It is related to what you quoted above, but I can not tell you more.

Nikola Semov

Alright fair enough. Thanks for the update!

I’ll be trying to fix this problem in the coming weekend, will make an update.

@LasseRegin if you managed to fix the problem, please let me know.

Thanks in advance to everyone.

@Nikola I’m afraid we are still experiencing issues with our LTE connection sporadically losing connection and never getting online again. This is with the new firmware 1.3.8 which supposedly should have fixed the issue.

Are you aware of this issue still?

Hi everyone,

I just managed to get a log section when the error just happened here . I don’t know if this might help, but maybe it does.

1 Like

Hello @LasseRegin,
Apologies for the late reply. The problem is solved in version 1.3.8 or later so you should not get such a problem. Check your APN and give me some logs at Debug level when the problem appears. I will also check @olivos22 logs for some clues.

Best Regards,
Nikola Semov

Ain’t the latest firmware 1.3.6? Or am I missing something… DIY-Gateway-Rak7249

Hello @olivos22 ,

Here is the latest 1.3.9 firmware version: https://downloads.rakwireless.com/LoRa/WisGateOS/WisGateOS_Latest_Firmware.zip

Best Regards,
Nikola Semov