RAK7258 can't connect after internet lost connection

Issue: RAK7258 can’t connect to TTN after internet lost connection

Setup: RAK7258 1.1.0063_Release r205, WiFi disabled, PoE TPLink TL-POE150S 48V ethernet connection

LoRa® Server: ttn-router-us-west

Details: Hello everyone, before starting this topic I have first searched the forum to see if there is already this problem reported or it is only in my Gateway configuration but I have not found anything.
I have a RAK7258 model gateway powered both to the internet and electrically by ethernet through PoE.

Everything works correctly until there is a loss in the internet service and the gateway is disconnected from the internet with the cable modem still on but without service.
When the service returns and the gateway is connected to the internet again, within the TTN console my gateway appears as Last Seen minutes ago when the internet connection was lost and it’s never as seen again until I reboot either software or hardware the gateway.

Within the gateway configuration there are some parameters that indicate how often the gateway should give connection signals or “ping” to the TTN servers and while the gateway is connected to the Internet I can see how this “ping” is repeated according to the second places in the configuration in the LoRa Packet Forwarder section until the internet connection is lost due to failures in my internet service.

Is there a way to determine what is wrong with my configuration?
Every time there is a disconnection my internet service my gateway does not connect again to the TTN servers and I cannot get this to happen automatically until I restart the gateway either by software or hardware.

I thank you in advance for your attention when reading this post and waiting for your help.


Solved, in my case I just put a 0 in the auto restart threshold to avoid restarting the packet forwarder if there is an internet disconnect and don’t use a static IP, just leave the protocol as DHCP client

Hope this works for someone else with a setup like mine.

Please close this thread!!

HI @ubuntoscar,
I’m glad that you’ve solved the problem. Anyway, this case will be forwarded to the dev team, so they could check if there is a bug.