RAK7258 Gateway and Join Request/Accept Loop


I have searched high and low through the forums and the internet and while there is a lot of discussion on the topic, I can’t seem to get my devices to join.

My current attempt is Chirpstack on EC2, Dragino GPS tracker, and a RAK7258. I’m using UDP packet forwarder in US915 network. I can see the accept/join on both RAK and Chirpstack. I’ve moved the gateway about 20m away as I wasn’t if that was a problem. I noticed that it seems that the frequency it’s trying to send the accept join on is 924500000 which seems to be out of the LoRa band? I’ve tried all combinations of regional settings in Chirpstack settings. I also tried the local onboard network server on the gateway with the same results.

Any idea where I should focus my troubleshooting? Any tips would be super helpful. If more diagnostic info would be helpful, just let me know.

I had it successfully working using AWS IoT Core using Basic Station and TLS. I could decode payload and everything was great! I haven’t been able to get the Basic Station and Chirpstack gateway working yet though.

Thanks for any help!