RAK7258 Not Connecting To ChirpStack [AWS]

Issue: My RAK7258 is 'Not Seen by Chirp Stack despite following everything in the tutorial of connecting ChirpStack via AWS Ubuntu

ALL tests giving the expected results, namely:

  • journalctl -u chirpstack-network-server -f -n 50
  • journalctl -u chirpstack-application-server -f -n 50
    journalctl -u chirpstack-gateway-bridge -f -n 50
    ALL indicate that they are online and running.

Anyone has any clue why this is happening?

My System log seems good

Setup: RAK7258

Server: ChipStack Installed on Ubuntu AWS

I haven’t changed my chirpstack- network-server from its default to US915… but would that impact the gateway being found by the chirpstack server hosted on AWS?

I have a feeling its mainly a connection issue between the two.

Thank you for ANY AND ALL help!

More love, more live

Hello @LoRaD the last week i have a lot of trouble setting up my VPS with chirpstack i have my server on SkySilk but ubuntu is the same independently from platform are you are using. Fisrt i used the guide in the chirpstack web without sucess results thats when i found the quide you mention and i have working chirpsatck in less than 20 minutes, really.
If you are seeing the web page in your web server a lot of work is done. Can you post your journalctl -u chirpstack-XXX-XXX dialog and verify if all the services are running?
even i must restart my VPS to “restart” all the services and make a sucessfull connection.
Plus are you check twice the toml files cause in this files are all the configuration you need to change

1 Like

You already have TWO other threads about this, please don’t create yet another.

Especially don’t create another while IGNORING the response your previous thread received and failing to answer the followup questions you were asked there!


Chris, I shall not, initially due to not knowing how the site worked and new updates/progress was made. I know it is bad etiquette, just under pressure from work to get this working, and no one replied. But finally someone has! Cheers.

Greeting, thats great to hear!

For my chirpstack-gateway-bridge:
I restarted it, everything is running

When I execute: journalctl -u chirpstack-gateway-bridge -f -n 50
I receive errors (logs from when I tried lora-server instead of chirpstack-gateway-bridge)

But thankfully it is connected to the MQTT.

For Chirpstack-Network-Server:
journalctl -u chirpstack-network-server -f -n 50

Which seems weird but when I check status, it is running ->

For Chirpstack-Application-Server:
It is also running

And it seems OK as well ->

I think the main problem is that I can not ping my IP Address in the RAK Diagnostics despite being able to ping google.com

And the funny thing is I have already made my security groups:

I am wondering why this is happening… The Legendary Todov is also helping me so I am praying I find the solution (this is one of my first work projects, need it to be solved)


You haven’t allowed any ICMP ping traffic through your firewall. Today it would be very unusual for a cloud instance to be setup to allow this and support inbound “ping”.

You could lookup how to configure this for your cloud provider, but if you do you probably want to turn it right back off again after the test.

Really it’s not going to show you anything you can’t get from other methods, eg, the logs, netcat in udp mode, etc.

1 Like

Thanks for the expert advice!

True, so what do you suggest to do? I am in a bit of a pickle as I have no obvious problems with the ChirpStack configuration (besides readjusting the configfile). The RAKwireless’ system log shows no error.

Is there any other way to test for potential errors?
Happy Turkey day

Make sure the packet forwarder on the gateway is really pointed at the right IP address.

Make sure the appropriate version of the gateway bridge is really running in the cloud.

Run a packet sniffer on the cloud instance monitoring udp port 1700 and see what you get.

Or (again on the cloud instance) kill the gateway bridge, install netcat (debian nc.traditional) and run nc -l -u 1700 and see if after a minute or two that gets any gibberish from the gateway with bits of json in it (maybe pipe into hexdump -C or even strings)

Do the above and try throwing random garbage at it from your pc, ie echo "hello" | nc -u cloud_external_ip 1700 - that would effectively be a sort of one-way “ping” over the UDP channel you should actually have open

1 Like