RAK811 no response

I bought a wislora-n (rak811-n based).
I only see


in serial port, I couldn’t able to send any command (boot jumper in boot 3,3V position, serial jumper in CRX-CTX).
I tried to flash it, but i got:

Only one tool, the RAK LoRaButton Upgrade Tool V1.0 work with one firmware: RAK811_HF_B_V3.0.0.0, but I unable to flash any other file.

Any help is greatly appreciated.

Hello! The firmware has been updated. You can refer to the documentation in this directory to burn the firmware. https://downloads.rakwireless.com/en/LoRa/WisNode/

Hi @szogi,

In our latest firmware for RAK811/WisNode, there is a bootloader which can be used to load the firmware.
According to your description, your WisNode has only a bootloader without a firmware in it.
You need to load a correct firmware into it according to the section 3 of this document:

Thanks for your reply, could you tell me what is the correct firmware file for this board? Is RAK811_HF_B_V3.0.0.0.bin not appropriate? I only could flash that file, I tried others, eg:

With the above files
“Enter boot mode success”, but it hangs at sending process:


I also tried the cubeprogrammer:

Are you following the documentation on how to wire boot.image

Hi @szogi,

You only need burn two files into RAK811, one is the bootloader file named “RAK811_BOOT_V3.0.0.0”, the other is the firmware file named “RAK811_HF_B_V3.0.0.0” if you want to use high frequency like EU868, US915, AS923, etc. These files can be found in RAK website:

Next, how to burn the bootloader file into RAK811? Please have a look at the section 2 of this document:
and how to burn the firmware file into RAK811? Please have a look at the section 3 of this document:
I think it is very clear and you can do it by yourself successfully according to the document.

Dear Nicholas,

Yes, i followed the doc (yes, it’s very clearly), jumper was at right position (between BOOT and 3V3 pin), I pressed the reset button, even so the cube programmer unable to communicate with the board.

17:08:16:272 : Serial Port COM4 is successfully opened.
17:08:16:273 : Port configuration: parity = even, baudrate = 115200, data-bit = 8, stop-bit = 1.0, flow-control = off
17:08:16:273 : No Init bits value is : 0
17:08:16:273 : Sending init command:
17:08:16:274 : byte 0x7F sent successfully to target
17:08:17:272 : Wait ends after 1 loop, dataready = 0, delay = 1000
17:08:17:272 : Timeout error occured while waiting for acknowledgement.
17:08:17:273 : No response from target received
17:08:17:273 : byte 0x7F sent successfully to target
17:08:17:373 : Wait ends after 1 loop, dataready = 0, delay = 101
17:08:17:373 : Timeout error occured while waiting for acknowledgement.
17:08:17:374 : No response from target received
17:08:17:374 : Error: Activating device: KO. Please, verify the boot mode configuration and check the serial port configuration. Reset your device then try again…

Dear @Fomi,

The firmware flash was successful, however as I wrote in the previous post may I unable to flash bootloader.


After flashing and reset, COM4:


If you have burned the bootloader into RAK811 or there is a bootloader in RAK811 already, you only need to flash a new firmware.
If there is no bootloader in RAK811, you need to flash the bootloader firstly, then flash the firmware.

Dear @Fomi,

So when I trying to flash the bootloader, I got this (device boot pins at 3V3). I tried another usb cable, computer, same. (I followed the doc, pushed the reset, etc…)

Hi @szogi,

Which RAK811 board are you using?
I’m sure the method i mentioned in the document is correct, if the hardware is OK and you connect it well.
Please check again according to the red string which is the Error information in you picture.
If it still doesn’t work, maybe you can try to flash the firmware into it through J-Link.

Hi @Fomi!

This is WisNode-Lora-N (868MHz) board v1.1 (1724).

Hello I use the wisDuo and I have the same problem.

When I connected the boot with GND jumper, I hit the connect button and your error was repeated.
Also, when I connect boot to 3V3 correctly, the same error will be repeated when I click the connect button to restart the device.
If you do not follow this wrong operation and the same error occurs, I suggest you find the boot pin and connect it to 3V3 during the connection process, then press the restart button on the board first, and then click connect to see if it is normal.

HI, I’ve got the same problem, I did my research and find that the problem seems to be the firmware published doesn’t work because was designed for ST microcontrller but the chip inside module in this partular version Wisnode V1.1 is Nano100 chip. See my previos post, when i consult for similar problems and didn’t receive any util response. Please, post the firmware for Nano100 chip in the website.

Sorry , I post the lik Wisnode-Lora with Rak811-N latest firmware