RAK811 Wisnode Lora Module v1.2 with Arduino UNO NOT WORKING

Hi, I have tried to connect TTN with RAK811 Wisnode Lora Module v1.2 on Arduino UNO, but it dosen’t work. I have researched and didn’t find how to work well.
I configured the module according to the following process.
Have I mistaken connecting jumper wire on the board RAK811 Wisnode Lora Module v1.2?

  1. set RAK811 Wisnode Lora Module v1.2 according to the “Get_Start_with_RAK811_WisNode-LoRa.pdf”.
    - BOOT LOADER ver 3.0.2
    - firmware ver 3.0.12 HF (AS923)
    - the response from RAK SERIAL PORT TOOL is following.
>>at+version
Firmware Version: RUI v3.0.0.12.H
OK
>>at+get_config=lora:status
at+get_config=lora:status
OK.
*************************************************
==============LoRaWAN Status List================
Work Mode: LoRaWAN
Region: AS923
Send_interval: 600s
Auto send status: false.
Join_mode: OTAA
DevEui: ****************
AppEui: ****************
AppKey: ********************************
Class: A
Joined Network:true
IsConfirm: true
AdrEnable: true
EnableRepeaterSupport: false
RX2_CHANNEL_FREQUENCY: 923200000, RX2_CHANNEL_DR:2
RX_WINDOW_DURATION: 3000ms
RECEIVE_DELAY_1: 1000ms
RECEIVE_DELAY_2: 2000ms
JOIN_ACCEPT_DELAY_1: 5000ms
JOIN_ACCEPT_DELAY_2: 6000ms
Current Datarate: 5
Primeval Datarate: 5
ChannelsTxPower: 0
UpLinkCounter: 0
DownLinkCounter: 0
===================List End======================
*************************************************
  1. conected TTN successfully. (pic1,pic2)

  1. changed uart baud rate to 9600 by ATcmd “at+set_config=device:uart:1:9600”, no response but I could open COM PORT by 9600. (pic3)

  1. connected RAK811 Wisnode Lora Module v1.2 with Arduino UNO.(pic4)
    - P1 : jumping CTX <-> RXD, CRX <-> TXD. Is this wrong?

  1. downloaded “Arduino Library” from GitHub.
  2. uploaded “JoinNetworkOTAA” in “RAK811/Arduino Library/RAK811/examples/”.Of course I replaced DevEui, AppEui and AppKey in the code.
  3. uploaded successfully but couldn’t connect with TTN.(pic5)

Hi,I have exactly the same problem that describes @takisd
Any idea what might be happening.
thanks!!

1 Like

Hi all,

It seems there are some issues on this usecase.
Actually, for the latest V3.x firmware, we haven’t tested it with Arduino, but i know it is important to support this usecase. So we will spend some time on it, and once we complete it, i’ll tell you ASAP.

1 Like

hi @takisd,
I have made the module work. I tell you my experience.
After performing all the updates, as you describe it,
Make the following connection between the Wisnode and my arduino Uno

Thanks to the explanation of @zabeelr, in the following post https://forum.rakwireless.com/t/rak811-problems/49/9?u=ncl17

I realized that the existing libraries for arduino don’t work, since the AT commands and their responses have changed.
I have updated these libraries (rudimentary)
https://github.com/ncl17/Wisnode-Arduino-Library

Another problem I encountered is the use of “softwareserial”, for being arduino Uno.
I have changed in softwareserial.h the value #define _SS_MAX_RX_BUFF 256, so that the response message is not cut.

I have added a basic example to the library, it also uses a DHT11 connected to pin 5, 5v and GND
send a payload with temperature, humidity and a random value

I hope you can understand since I don’t speak English very well
best regard!

3 Likes