RAK8213 on a RAK7391 gateway


I bought the RAK8213 4G board along with the RAK7391 gateway. The problem is that I can’t find the device address in order to communicate with it. Inserting or disconnecting it adds/removes nothing to the /dev directory. I tried lsusb and lspci and I still got no result.
The board seems to be working because there is a blue and a green LED that are ON, and a red LED that is flashing.
Does someone have any idea how I can make it work?
Thank you so much in advance.

To give more details, the card is inserted on the miniPCIe slot #2, I tried it on the other slots but it doesn’t work either. It’s worth noting that on the 3rd slot, it blinks for some seconds. However, on the 2nd one it blinks infinitely.

Hello, @o.benkhalfallah Are you using the RAK7391 with the RAK PiOS or with Raspbian OS? Make sure the USB2 ports are on.
Make sure you have this line dtoverlay=dwc2,dr_mode=host in the /boot/config.txt file.

1 Like

Hello @velev
Thank you for your fast reply.
Yes, I am using RAK PiOS. That line did solve the problem.
Thank you so much. Have a nice weekend
Best regards

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.