Running external antenna cables?

Issue: I need to run the two external antennas outside of the room where the RPi/RAK2013 is located. I have already tried; I ran just one antenna cable and put the antenna outside of the room. The other antenna is still directly connected to the case. When I turned the Pi on, the modem was rebooting and non-responsive. I need to know how to run antenna cables in the proper way to get signal from outside of the room.

Setup: RPi Model 3 B+, RAK2013 connected to Pi via UART, powered from UART.

Antenna 1:
One end of cable with SMA connector, connects to RAK2013 case, other end has SMA connector, runs outside of room and connects to LTE antenna.

Antenna 2: Unchanged, connected directly to RAK2013/RPi case.

RAK2013 becomes unresponsive, reboots, when one antenna is ran to a distance outside of room.

The cable I’m using is LMR240. The run is about ~10 feet. (~3 meters).

Please let me know what to do here to get it working properly. Thanks for your help.


Assuming it all works when you don’t use the cable run - where is the cable run next to - there is a limit to how much the copper shield can shield - if it’s next to big power cables, try re-routing.

Hei @Jordan,

You seem to be talking about RAK2013, but you are connecting SMA cables. Correct me if I am wrong but RAK2013 only has iPEX connectors?
Are we talking about the same thing.
Are you sure the issue is the antennas, was your setup working when you used it with the provided iPEX antennas?


@nmcc – It is not next to any other cables. Just a concrete wall.

@Hobo – You are correct, I just didn’t explain all the details. From the RAK2013 iPEX connector, it has an iPEX to SMA connector that is attached to the antenna hole of a Pilot Gateway Enclosure. From the SMA connector, it is coupled to another SMA connector(female to male), and then ran about a distance of ~3 meters/10 feet over LMR-240, and then terminated to another SMA connector, and connected to the antenna.

The modem works fine when this antenna extension cable is not in use. When it is, the modem acts strangely, loses its configuration(reverts to 115200 baud from 921600), power cycles, and is mostly unresponsive. I’m wondering if anyone has experience with this or has the directions to run antenna cables properly. Is it possibly because it has some sort of difference in power level from the antennas? Does the modem not have enough power for longer antenna cable runs?

Thanks for everyone’s help.


Hei @Jordan

@jmarcelino any idea what might be the issue?
It seems to me that this should not be happening as if the cable is terminated properly even if there is connector and cable loss there should be no such drop in power.
You do have an unusual number of connectors, but I doubt this is the case.
What I can share that I have experienced is what happened with the RAK8213 I was testing. It had similar issues being unresponsive and it was due to insufficient power, because the Quectel was quite hungry and I was powering the Raspberrry Pi with a low quality USB cable. The situation improved upon using another cable and power supply.
To this end, how are you powering the setup?


Hi @Jordan

Can you tell us more about your software configuration? What Linux distribution and also which device are you using to access the modem, is it /dev/ttyAMA0 or /dev/serial0

It may sound like a strange question for what is seemingly an hardware issue but if you happen to be using the mini UART (software UART) you can run into strange issues like these.