Slow internet on RAK2013

Hi, I’m getting about .05Mbps down/up with my RAK2013 on Verizon in the US. How can I verifiy I am using LTE and not 2G/3G or some other kind of service?

Thanks,

Jordan

Hi , can you give the the output of AT+COPS? command?

AT+COPS=?

+COPS: (2,"Verizon Wireless","VzW","311480",7),(1,"T-Mobile","T-Mobile","310260",7),(1,"311 490","311 490","311490",7),,(0-4),(0-2)

OK

If i try to do AT+COPS=1,0,“Verizon Wireless”,7 I get CME error 22.
If I try to do AT+COPS=1,0,“VzW”,7 I get CME error 22.
If I try to do AT+COPS=1,0,“Verizon”,7 I get CME error 30.

However, sudo pppd call gprs still connects and gives me an IP.

Sorry, I realized I didn’t do the command you actually asked for:

AT+COPS?

+COPS: 1

OK

1.Please confirm that you can successfully "ping -I ppp0 8.8.8.8" after "sudo pppd call gprs", and then send me the entire log of "sudo pppd call gprs" just now.
2. Then, end pppd and execute "at+cops?" in minicom.

[email protected]:~ $ sudo pppd call gprs
pppd options in effect:
debug           # (from /etc/ppp/peers/gprs)
nodetach                # (from /etc/ppp/peers/gprs)
persist         # (from /etc/ppp/peers/gprs)
dump            # (from /etc/ppp/peers/gprs)
noauth          # (from /etc/ppp/peers/gprs)
remotename 3gppp                # (from /etc/ppp/peers/gprs)
/dev/ttyAMA0            # (from /etc/ppp/peers/gprs)
115200          # (from /etc/ppp/peers/gprs)
lock            # (from /etc/ppp/peers/gprs)
connect chat -s -v -f /etc/chatscripts/quectel-chat-connect -T we01.vzwstatic           # (from /etc/ppp/peers/gprs)
disconnect chat -s -v -f /etc/chatscripts/quectel-chat-disconnect               # (from /etc/ppp/peers/gprs)
nocrtscts               # (from /etc/ppp/peers/gprs)
modem           # (from /etc/ppp/peers/gprs)
asyncmap 0              # (from /etc/ppp/options)
lcp-echo-failure 4              # (from /etc/ppp/options)
lcp-echo-interval 30            # (from /etc/ppp/options)
hide-password           # (from /etc/ppp/peers/gprs)
novj            # (from /etc/ppp/peers/gprs)
novjccomp               # (from /etc/ppp/peers/gprs)
ipcp-accept-local               # (from /etc/ppp/peers/gprs)
ipcp-accept-remote              # (from /etc/ppp/peers/gprs)
ipparam 3gppp           # (from /etc/ppp/peers/gprs)
noipdefault             # (from /etc/ppp/peers/gprs)
ipcp-max-failure 30             # (from /etc/ppp/peers/gprs)
defaultroute            # (from /etc/ppp/peers/gprs)
usepeerdns              # (from /etc/ppp/peers/gprs)
noccp           # (from /etc/ppp/peers/gprs)
noipx           # (from /etc/ppp/options)
abort on (BUSY)
abort on (NO CARRIER)
abort on (NO DIALTONE)
abort on (ERROR)
abort on (NO ANSWER)
timeout set to 30 seconds
send (AT^M)
expect (OK)
^M
OK
 -- got it

send (ATE0^M)
expect (OK)
^M
^M
OK
 -- got it

send (ATI;+CSUB;+CSQ;+COPS?;+CGREG?;&D2^M)
expect (OK)
^M
^M
Quectel^M
EG95^M
Revision: EG95NAFBR05A04M4G^M
^M
SubEdition: V03^M
^M
+CSQ: 25,99^M
^M
+COPS: 1,0,"Verizon Wireless",7^M
^M
+CGREG: 0,1^M
^M
OK
 -- got it

send (AT+CGDCONT=1,"IP","we01.vzwstatic",,0,0^M)
expect (OK)
^M
^M
OK
 -- got it

send (ATD*99#^M)
expect (CONNECT)
^M
^M
CONNECT
 -- got it

Script chat -s -v -f /etc/chatscripts/quectel-chat-connect -T we01.vzwstatic finished (pid 3248), status = 0x0
Serial connection established.
using channel 7
Using interface ppp0
Connect: ppp0 <--> /dev/ttyAMA0
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x9c06c58d> <pcomp> <accomp>]
rcvd [LCP ConfReq id=0x16 <asyncmap 0x0> <auth chap MD5> <magic 0xa0f403bd> <pcomp> <accomp>]
No auth is possible
sent [LCP ConfRej id=0x16 <auth chap MD5>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x9c06c58d> <pcomp> <accomp>]
rcvd [LCP ConfReq id=0x17 <asyncmap 0x0> <magic 0xa0f403bd> <pcomp> <accomp>]
sent [LCP ConfAck id=0x17 <asyncmap 0x0> <magic 0xa0f403bd> <pcomp> <accomp>]
sent [LCP EchoReq id=0x0 magic=0x9c06c58d]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
rcvd [LCP DiscReq id=0x18 magic=0xa0f403bd]
rcvd [LCP EchoRep id=0x0 magic=0xa0f403bd 9c 06 c5 8d]
rcvd [IPCP ConfReq id=0xc]
sent [IPCP ConfNak id=0xc <addr 0.0.0.0>]
rcvd [IPCP ConfNak id=0x1 <addr 63.x.x.x> <ms-dns1 198.x.x.x> <ms-dns2 198.x.x.x>]
sent [IPCP ConfReq id=0x2 <addr 63.x.x.x> <ms-dns1 198.x.x.x> <ms-dns2 198.x.x.x>]
rcvd [IPCP ConfReq id=0xd]
sent [IPCP ConfAck id=0xd]
rcvd [IPCP ConfAck id=0x2 <addr 63.x.x.x> <ms-dns1 198.x.x.x> <ms-dns2 198.x.x.x>]
Could not determine remote IP address: defaulting to 10.64.64.64
local  IP address 63.x.x.x
remote IP address 10.64.64.64
primary   DNS address 198.x.x.x
secondary DNS address 198.x.x.x
Script /etc/ppp/ip-up started (pid 3266)
Script /etc/ppp/ip-up finished (pid 3266), status = 0x0

ping:

[email protected]:~ $ ping -I ppp0 8.8.8.8
PING 8.8.8.8 (8.8.8.8) from 63.x.x.x ppp0: 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=53 time=279 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=53 time=84.9 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=53 time=92.9 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=53 time=91.8 ms
64 bytes from 8.8.8.8: icmp_seq=5 ttl=53 time=94.8 ms
64 bytes from 8.8.8.8: icmp_seq=6 ttl=53 time=111 ms
64 bytes from 8.8.8.8: icmp_seq=7 ttl=53 time=77.7 ms
64 bytes from 8.8.8.8: icmp_seq=8 ttl=53 time=86.7 ms
64 bytes from 8.8.8.8: icmp_seq=9 ttl=53 time=385 ms
64 bytes from 8.8.8.8: icmp_seq=10 ttl=53 time=104 ms
^C
--- 8.8.8.8 ping statistics ---
10 packets transmitted, 10 received, 0% packet loss, time 9011ms
rtt min/avg/max/mdev = 77.733/141.061/385.499/99.038 ms

minicom:

AT+COPS?

+COPS: 1,0,"Verizon Wireless",7

OK

"at+cops?" list current network operators.

AT+COPS=?

+COPS: (2,"Verizon Wireless","VzW","311480",7),(1,"311 490","311 490","311490",7),(1,"T-Mobile","T-Mobile","310260",7),,(0-4),(0-2)

OK

Sorry, my last reply was misleading.
The command “AT+COPS?” will query the currently selected network operator.

No problem, do you need anything else?

If at+cops? can show some information, it means that rak2013 has successfully selected operator.

Jordan ,

From the log you sent , it is eactly Verizon LTE network . And looks signal is normal level as well .
1, UART is 115200bps .
2, It has LTE diversity antenna ?

If you requirs high speed , you could manage to test
1, using USB instead
2, using QMI_WWAN to replace PPP
3, connect one more antenna .

Hi Rick,

How do I use USB instead?

How do I use QBI_WWAN to replace PPP?

I appreciate your help!

I have both antennas that came from RAK wireless plugged in. Do you recommend me getting a different set of antennas? Thanks again!

Jordan

Thank you.

Can I change the UART speed to higher than 115200bps? Will it go up to 921600bps? Where would I make this change?

Thanks,
Jordan

1.Use command "sudo gateway-config", choose “Configure LTE Module”, select “disable LTE Module”, then reboot gateway
2.Use command minicon connect to the Rak2013
minicom -D /dev/ttyAMA0 -b 115200
3.Input “at+ipr=921600”

4.exit minicom

5.Use command minicon connect to the Rak2013
minicom -D /dev/ttyAMA0 -b 921600

6.Input "at&w"

7.exit mimnicom

8.Use command "sudo gateway-config", Choose “Configure APN name”, set the APN name and baud rate for pppd

9.Choose “Configure LTE Module”, select “Enable LTE Module”, set the module power on when the system os starts.

Jordan ,

Porting USB driver in Linux (if it is linux kernel), and then enable QMI and dail up the data via connection manager tool attached as well .

Regards,
RG

(Attachment Quectel_ConnectManager_SR01A01V29.zip is missing)

(Attachment Quectel_Linux_USB_Drivers_Sample_V1.0.0.tgz is missing)

(Attachment Quectel_WCDMA&LTE_Linux_USB_Driver_User_Guide_V1.9_Preliminary_20190325.pdf is missing)

(Attachment use_quectel-modules_on_ubuntu.docx is missing)

Hi Rick, it appears that your attachments are not availabe/missing:

Could you please re-attach them? Thank you.

Hi ZhuQI, will this speed up the connection? Or is it bottlenecked by something else such as pppd? Thanks for everyone’s help this is great.

Jordan

The default rate of ttyAMA0 is 115200, and the maximum rate is 14KB/s.
The speed of ttyAMA0 can be changed to 921600, which is 112KB/s.

Your SIM card must be 4G.

Jordan , could you leave the email here , i will forward to you via email .thanks

[email protected]

Thank you!