SSH into RAK7244 not working AGAIN

I posted the same issue in another thread, but it got closed since I marked it as resolved!
But with further investigation, it was not actually resolved: original post

Following on that thread, I flashed the memory using RAK firmware again and then connected the device to my monitor, the monitor didn’t show anything!
Any idea what should I be doing next?

P.S.: I hadn’t connected the GPS antena, could that cause the problem?

Was the monitor connected before you powered it up?

Whilst it seems very odd, you could try a standard Raspberry Pi image to see what happens?

I’d not imagine the GPS not having an aerial plugged in would cause an issue, have you considered just plugging it in to try - not a huge imposition!

Was the monitor connected before you powered it up?

No, I turned it on, then plugged in the monitor.

Whilst it seems very odd, you could try a standard Raspberry Pi image to see what happens?

I actually did, nothing happened! Same result.

I currently don’t have the GPS antenna, should check with my friend to see if he got it!

Soooooooo, what do you think may be a good test to try next then?

I wanna do 2 things:

  1. Use another SD card and flash it with RAK firmware.
  2. Get the GPS antenna from my friend which I probably will have to wait till tomorrow!

But hopefully that hasn’t damaged the board since in the starter guide there’s a warning that says don’t power on the device without GPS antenna!

P.S. I’m referring to this: Starter guide

I’m shaking my head in despair here. This is just guessing rather than trying things methodically.

The Pi, like many other computers, but particularly the Pi, needs the monitor plugged in before you turn it on.

Is that not the most obvious thing to test after the “plug in monitor after power-on” test failed?

I actually wanted to test my HDMI cable and I did the exact same thing with my other PI, which it worked completely fine. Meaning that I turned it on and then plugged the monitor in.
But i’ll test that now and will let you know!

Ok, just tested by plugging the monitor first and then turning the device on. Same result. I see a message on TV which says: “Invalid Format”. That’s new to me!

Today I received a new RAK wireless. AND THE SAME THING HAPPENED AGAIN! Can’t SSH to it!!
I feel like i’m doing something wrong, but there’s a very small margin for error. Here is what I did:

  1. Connected all antennas (two lower ones are LTE, upper left one is LoRa antenna and upper right one is GPS antenna)
  2. Connected ethernet cable
  3. Plugged it into power and waited a bit and then tried to SSH
    Nothing happens! (refused connection)
    I also tried connecting to the monitor, but it doesn’t show anything?
    How likely is it that I’ve received 2 faulty devices??

@Sooriland ,

Where is the second end of that Ethernet cable connected to?
What about the IP address, what IP address are you trying to connect to?


The second end of the ethernet cable is connected to my Apple monitor which gathers its IP address using DHCP. So, when I go to Network tab in Settings I can see the IP address.
Also connecting the device to monitor doesn’t show anything, should it not show something regardless of me connecting to the device through SSH?

@Sooriland ,

Not familiar with Apple hardware to be honest, but since when does a monitor have an IP address ?
As for the Gateway, by default the firmware does not work as a DHCP client when you connect the Ethernet interface, thus if you are trying to assign an IP to it via a DHCP server it will not work. It seems to me this is the issue.
Is it possible to connect via Wi-Fi to the AP that should work by default and SSH to the address so you can set proper static IP addresses in order for your gateway to become a part of the LAN?


I’ve still got my Mac Plus from when I started doing Apple, and I’ve not seen a monitor with ethernet but the OP may mean an iMac.

In which case, a cross over cable and appropriate settings may work.

I’d be inclined to go back to trying an HDMI monitor + keyboard to see it boot.

When I’m setting up a RAK gateway, I just select the WiFi AP as per instructions, so there’s nothing Mac’ish going on in that area. I will also have a Pi plugged in to Ethernet and use LanScan that lists active IP addresses with the MAC address.

It’s actually a discontinued old mac monitor, not an iMac: old monitor

But yeah, I’ve tried connecting to my TV (not the Apple monitor) but I get “Invalid Format” error!

wow, my bad! I tried the default wifi IP address and it worked fine on this new device! Thank you

1 Like

Where on earth did you plug in the ethernet cable???

I was thinking of something that was definitely a normal HDMI monitor!

But it sounds like you have got started.

Where on earth did you plug in the ethernet cable???

As you can see in the picture, there’s an ethernet port behind the monitor.

I was thinking of something that was definitely a normal HDMI monitor!

I still don’t understand why my normal TV shouldn’t work when it’s working with normal Raspberry pi 4

OK, ethernet port on a monitor, but it’s a monitor, not a computer, I guess you can plug in a monitor to the USB port, but where’s the processor??

You never previously confirmed your TV was working with a Raspberry Pi 4.

I’m pretty sure that RAK use a “normal” Raspberry Pi 4 as well.

Did you try a normal copy of Raspberry Pi OS with the gateway?

You did manage to connect to it, right ?

I should’ve clarified better. My Mac monitor with the ethernet port connects to my laptop via thunderbolt cable.
I thought I did confirm that my TV worked with the normal Raspberry PI and I did try switching their SD card to see if it works, but RAK raspberry didn’t work (I’m assuming it had a hardware issue).