The newest software for RAK LoRa gateway! Updating

Hi, everyone

Please check the following list about UART GPS and I2C GPS:


As you see, why we use I2C GPS for RAK7243 with LTE? Because RPi has only one UART, and it must be used for RAK2013.

About the software for them:

  1. If you want to use RAK831 + RPi or RAK2245 + RPi or RAK7243 without LTE, please download the gateway image directly from RAK website:
    https://www.rakwireless.com/en/download/LoRa/RAK2245-Pi-HAT#Firmware
    If you want to use RAK7243 with LTE, please download the gateway image from RAK website, and select the one named “RAK7243_LTE_…”:
    https://www.rakwireless.com/en/download/LoRa/Pilot-Gateway-Pro-RAK7243#Firmware
    If you want to use RAK833 + RPi or RAK2247 + RPi though USB interface, please download the gateway image from here:
    https://www.rakwireless.com/en/download/LoRa/RAK2247-Mini-PCIe
    If you want to use RAK833 + MT7628 + OpenWRT or RAK2247 + MT7628 + OpenWRT, please download the gateway image from here:
    https://www.rakwireless.com/en/download/LoRa/RAK833-Pcie-Gateway#Firmware
  2. If you want to play the LoRa gateway, and want the source code of them, just find all the source code of them in RAK’s Github repositories:
    1. This one is used for RAK831, RAK2245 Pi Hat, and RAK7243 without LTE, and it is based on Raspbian OS:
      https://github.com/RAKWireless/RAK2245-RAK831-LoRaGateway-RPi-Raspbian-OS
    2. This one is used for RAK7243 with LTE, and it is based on Raspbian OS:
      https://github.com/RAKWireless/RAK7243-LTE-LoRaGateway-RPi-Raspbian-OS
    3. This one is used for RAK833/RAK2247 + MT7628 + OpenWRT:
      https://github.com/RAKWireless/RAK833-LoRaGateway-OpenWRT-MT7628

That’s all!
My team have worked very hard to release them during the past two month, and just release the last one of them today.
Just enjoy them. :slight_smile:

5 Likes

Thanks @Fomi for the OS.

I am trying to up the RAK7243 with LTE, basically a combination of [Pi3+RAK2245+RAK2013 series Cellular].

Will update here once I’ve successfully configured and tested.

Regards,
Srikapardhi

Hi @sri

I believe gateway os is no longer supported so perhaps in est your time in a Raspbian based image

Regards
Vladislav

Hi @Hobo,

Can you redirect me to the right OS, so that I can setup the gateway?

Thank you much.

Hi @sri

https://github.com/RAKWireless/RAK7243-LTE-LoRaGateway-RPi-Raspbian-OS

I believe this should do.

Hi @Hobo will that OS work for LTE also?

I’m finding it very hard to get documentation and anything related to cellular 2013 module.

Have tested it sorry, can’t say. Should thought.

@Hobo thanks for your inputs.

I’m testing multiples OS and gateways. Will share my inputs once the gateway is up and running.

For one gateway with RAK2245, the gateway is up and running without any issues.

I’m trying for the one with LTE.

Nice looking forward to your feedback

I’ve updated the above information about RAK products firmware.

Hi, any chance of a Docker version of the RAK7243 software (for use with balenaCloud - https://www.balena.io/)?

Hi, @dapendragon

I’m sorry, we have a Docker version firmware for RAK7243 without LTE, but it can only be used with Azure Cloud.

Is it possible to ssh into the Pi and update the software from 2.4R to 2.8R? Is it even necessary with the recent releases? My gateway is on the roof and not easy to reflash the SD card.

Thanks!

J

Hi, @JSpot

Yes, it is possible to update the firmware through SSH, but we need to make a update file for you.
It may take 1 day to do it, just wait for me. I’ll reply ASAP.

Hi, @JSpot

Done!
You can download the update file from here:

This file is only used for RAK2245 Pi HAT LoRa Gateway, if your gateway is this one, you can do as follow:

  1. copy this update file into you RAK2245 Pi HAT LoRa gateway;
  2. excute “tar -zxvf update_2.4_to_2.8.tgz” to uncompress the file;
    i guess you ssh with it through ethernet, right? if it isn’t, just ignore step 3-4 and jump to step 5 directly.
  3. Enter the folder <update_2.4_to_2.8>, and open the file dhcpcd.conf;
  4. at the end of the file, you can see the following content:

    modify the IP address and router address according to your router;
  5. excute “sudo ./update.sh” command to update the firmware;
  6. after done, restart the LoRa Gateway;
  7. When the LoRa Gateway power on, you can ssh with it and use the command “sudo gateway-config” to config it again.
1 Like

@Fomi thanks for the help!

@FomiI

I get a lot of errors with your update (note I added an extra ‘t’ to http in my post below, it would not let me post multiple links)…

[email protected]:~/update_2.4_to_2.8 $ sudo ./update.sh
Reading package lists… Done
Building dependency tree
Reading state information… Done
iproute2 is already the newest version (4.9.0-1+deb9u1).
iw is already the newest version (4.9-0.1).
iw set to manually installed.
procps is already the newest version (2:3.3.12-3+deb9u1).
util-linux is already the newest version (2.29.2-1+deb9u1).
Suggested packages:
apparmor
The following NEW packages will be installed:
dns-root-data dnsmasq dnsmasq-base haveged hostapd libhavege1
libnl-route-3-200
0 upgraded, 7 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,074 kB of archives.
After this operation, 2,771 kB of additional disk space will be used.
Get:1 htttp://archive.raspberrypi.org/debian stretch/main armhf dnsmasq-base armh f 2.76-5+rpt1+deb9u1 [385 kB]
Err:2 htttp://raspbian.raspberrypi.org/raspbian stretch/main armhf dns-root-data all 2017072601~deb9u1
404 Not Found [IP: 93.93.128.193 80]
Get:3 http://mirror.sjc02.svwh.net/raspbian/raspbian stretch/main armhf libnl-ro ute-3-200 armhf 3.2.27-2 [113 kB]
Get:4 htttp://archive.raspberrypi.org/debian stretch/main armhf dnsmasq all 2.76- 5+rpt1+deb9u1 [16.1 kB]
Get:5 htttp://archive.raspberrypi.org/debian stretch/main armhf hostapd armhf 2:2 .6-21~bpo9~rpt1 [497 kB]
Get:6 http://mirror.sjc02.svwh.net/raspbian/raspbian stretch/main armhf libhaveg e1 armhf 1.9.1-5+deb9u1 [24.9 kB]
Get:7 htttp://mirror.sjc02.svwh.net/raspbian/raspbian stretch/main armhf haveged armhf 1.9.1-5+deb9u1 [33.4 kB]
Fetched 1,069 kB in 1s (655 kB/s)
E: Failed to fetch htttp://raspbian.raspberrypi.org/raspbian/pool/main/d/dns-root -data/dns-root-data_2017072601~deb9u1_all.deb 404 Not Found [IP: 93.93.128.193 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-mis sing?


  • update success! *

Try execute “sudo apt update” before executing “sudo ./update.sh”.

The document of the latest firmware has been released today, please refer to it:
https://www.rakwireless.com/en/download/LoRa/Pilot-Gateway-Pro-RAK7243

Thanks for the Update-File, worked perfectly for me (over WiFi ssh)