Track-It RAK2171 can't Join anymore to Helium network server

After of few months of successful working with Helium network, one of my Track-It RAK2171 devices, can’t join anymore to the LoRaWAN network server at Helium Network. Looking at the Helium console, I see that it sends Join Request every 5-10sec, network server always sends back Join Accept, but my device continue to repeat the procedure for Joining. This consumes a lot of Data Credits :confused: and of course not do any useful job as tracking device. Tried to re-power it several times, change mode to P2P and back to LoRaWAN with app, but no success last few days.
Any hint how to make a factory reset or something similar ?

SOLVED: After reading post into this topic: RAK5205 Join Accepted not received - #8 by carlrowan I moved to another neighborhood and tried again , this time successfully joined Helium network. Looks like some of the gateways around my home doesn’t play nice with Join accept responses.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.