Very slow internet on RAK7243

Hi,
Working with RAK7243 in the US and getting ~0.05Mpbs when trying to access the internet. Tried with Verizon and Webbing and got about the same.

and another question - I have the ppp0 up (in ifconfig) but no internet access.
I set in minicom to AT+COPS=0 and changed in the gateway-config to ‘Disable LTE automatic…’ and run ‘sudo pppd call gprs’. Please see below that command output -

Thanks

[email protected]:~ $ sudo pppd call gprs
pppd options in effect:
debug # (from /etc/ppp/peers/gprs)
nodetach # (from /etc/ppp/peers/gprs)
dump # (from /etc/ppp/peers/gprs)
noauth # (from /etc/ppp/peers/gprs)
remotename 3gppp # (from /etc/ppp/peers/gprs)
/dev/ttyAMA0 # (from /etc/ppp/peers/gprs)
921600 # (from /etc/ppp/peers/gprs)
lock # (from /etc/ppp/peers/gprs)
connect chat -s -v -f /etc/chatscripts/quectel-chat-connect -T wbdata # (from /etc/ppp/peers/gprs)
disconnect chat -s -v -f /etc/chatscripts/quectel-chat-disconnect # (from /etc/ppp/peers/gprs)
nocrtscts # (from /etc/ppp/peers/gprs)
modem # (from /etc/ppp/peers/gprs)
asyncmap 0 # (from /etc/ppp/options)
lcp-echo-failure 4 # (from /etc/ppp/options)
lcp-echo-interval 30 # (from /etc/ppp/options)
hide-password # (from /etc/ppp/peers/gprs)
novj # (from /etc/ppp/peers/gprs)
novjccomp # (from /etc/ppp/peers/gprs)
ipcp-accept-local # (from /etc/ppp/peers/gprs)
ipcp-accept-remote # (from /etc/ppp/peers/gprs)
ipparam 3gppp # (from /etc/ppp/peers/gprs)
noipdefault # (from /etc/ppp/peers/gprs)
ipcp-max-failure 30 # (from /etc/ppp/peers/gprs)
defaultroute # (from /etc/ppp/peers/gprs)
usepeerdns # (from /etc/ppp/peers/gprs)
noccp # (from /etc/ppp/peers/gprs)
noipx # (from /etc/ppp/options)
abort on (BUSY)
abort on (NO CARRIER)
abort on (NO DIALTONE)
abort on (ERROR)
abort on (NO ANSWER)
timeout set to 30 seconds
send (AT^M)
expect (OK)
AT^M^M
OK
– got it

send (ATE0^M)
expect (OK)
^M
ATE0^M^M
OK
– got it

send (ATI;+CSUB;+CSQ;+COPS?;+CGREG?;&D2^M)
expect (OK)
^M
^M
Quectel^M
EG95^M
Revision: EG95NAFBR05A04M4G^M
^M
SubEdition: V03^M
^M
+CSQ: 15,99^M
^M
+COPS: 0,0,“Pelephone”,2^M
^M
+CGREG: 0,5^M
^M
OK
– got it

send (AT+CGDCONT=1,“IP”,“wbdata”,0,0^M)
expect (OK)
^M
^M
OK
– got it

send (ATD*99#^M)
expect (CONNECT)
^M
^M
CONNECT
– got it

Script chat -s -v -f /etc/chatscripts/quectel-chat-connect -T wbdata finished (pid 1798), status = 0x0
Serial connection established.
using channel 1
Using interface ppp0
Connect: ppp0 <–> /dev/ttyAMA0
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xb54534f4> ]
rcvd [LCP ConfReq id=0x0 <asyncmap 0x0> <magic 0x17af8cb2> ]
No auth is possible
sent [LCP ConfRej id=0x0 ]
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0xb54534f4> ]
rcvd [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x17af8cb2> ]
sent [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x17af8cb2> ]
sent [LCP EchoReq id=0x0 magic=0xb54534f4]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
rcvd [LCP DiscReq id=0x2 magic=0x17af8cb2]
rcvd [LCP EchoRep id=0x0 magic=0x17af8cb2 b5 45 34 f4]
rcvd [IPCP ConfNak id=0x1 <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14> <ms-wins 10.11.12.13> <ms-wins 10.11.12.14>]
sent [IPCP ConfReq id=0x2 <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14> <ms-wins 10.11.12.13> <ms-wins 10.11.12.14>]
rcvd [IPCP ConfNak id=0x2 <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14> <ms-wins 10.11.12.13> <ms-wins 10.11.12.14>]
sent [IPCP ConfReq id=0x3 <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14> <ms-wins 10.11.12.13> <ms-wins 10.11.12.14>]
rcvd [IPCP ConfReq id=0x0]
sent [IPCP ConfNak id=0x0 <addr 0.0.0.0>]
rcvd [IPCP ConfRej id=0x3 <ms-wins 10.11.12.13> <ms-wins 10.11.12.14>]
sent [IPCP ConfReq id=0x4 <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14>]
rcvd [IPCP ConfReq id=0x1]
sent [IPCP ConfAck id=0x1]
rcvd [IPCP ConfNak id=0x4 <addr 10.65.219.174> <ms-dns1 8.8.8.8> <ms-dns2 8.8.4.4>]
sent [IPCP ConfReq id=0x5 <addr 10.65.219.174> <ms-dns1 8.8.8.8> <ms-dns2 8.8.4.4>]
rcvd [IPCP ConfAck id=0x5 <addr 10.65.219.174> <ms-dns1 8.8.8.8> <ms-dns2 8.8.4.4>]
Could not determine remote IP address: defaulting to 10.64.64.64
not replacing default route to eth0 [192.168.10.1]
local IP address 10.65.219.174
remote IP address 10.64.64.64
primary DNS address 8.8.8.8
secondary DNS address 8.8.4.4
Script /etc/ppp/ip-up started (pid 1835)
Script /etc/ppp/ip-up finished (pid 1835), status = 0x0
Thanks

Hello, @sagis
You can try https://github.com/RAKWireless/quectel-CM-for-rpi .

Thanks @ZhuQI,
I installed it but no internet.

  1. How can I check that if it was connected ?
  2. What should be in ‘Configure LTE module’ In gateway-config ?
  3. ‘Configure APN Name’ in gateway-config ignored ?
    Thanks

Please make sure you have connected rak2013 and Raspberry Pi via usb cable.

Then, through the ifconfig command, you should see a network interface named wwan0.

Please select “Disable LTE Automatic Dial-up” in the sudo gateway-config command and restart the gateway.

Then, go to the directory /usr/local/rak/qmi and execute “sudo ./quectel-CM -s your_apn_name”. Under normal circumstances, you can connect to the internet.