WisToolbox freezing on white screen on Debian 11!

Hi

I run Wistoolbox 1.3.0 (AppImage) on Debian 11. I succeed to connect it with my RAK3172. Then I select to create a new template, select the board and when I click next all I get is a full white screen and nothing else !
What to do ?

Thanks

Vincèn

Hi @vincen ,

I already reported the issue to the team. I will get back to you once I got any words from them asap.

Thanks, it’s also impossible to get identified with RAK Login. When I click on button in app it opens browser to login, then once logged browser asks if I want to open the external link to app, I say yes but then nothing happens ! App keeps being unlogged but not sure if it matters or not !

Here are tests with both versions of Wistoolbox for Desktop (Linux edition):
→ snap version (that personnaly I don’t like at all as it’s closed system and obliges to install snapd on your system…): unable to see any USB device, but template part is working fine.
→ AppImage version: able more or less depending of your luck with device through USB but template part is broken

Both apps are unable to identify with RAK login system.

Let me know if you need additional tests :slight_smile:

How to know when a new release is avalaible ?

Hi @vincen ,

I am discussing this issue on the team now. I will let you know for any progress. As for the next release, there is no definite time yet. Not sure if we will have something for next month. But surely, if we found anything about this specific issue. I will let you know asap.

The RAK ID integration might be related to the issue you have with Debian. We can probably leave it for now and focus first on the core functionality of WisToolBox. Once we are good, we can check again the RAK ID and work on your templates.

Hi @vincen ,

You can get the latest build here 1.3.1.

However, the team only using Ubuntu and wont be able to confirm with Debian 11.

As for the USB, this is the note they gave me (maybe some permission setting is also available in Debian).

image

yep I agree although the new version you indicate below is on good way to solve that issue ! It’s not yet working but at least once identified on rakwireless website it comes back by itself in Wistoolbox app (but the app still keeps unidentified) :slight_smile:

Thanks for link :wink: May I suggest that version be indicated in files names on your files server to make it a lot easier to find out if a new version is avalaible or not ? :smiley:

Should not make much differences as Ubuntu is based on Debian :slight_smile:

No idea what it is but for AppImage there are no such settings. All you need is to add linux user in dialout group !

For that version it’s a lot better than previous one !

→ I connect the RAK3172 at my computer, starts the app and then it discovers the device. It just displays a warning that I have to manually select the type of device as it could not find it by itself. No problem I select my board and then it communicates with it !
It just complains that it can’t get all details of board and that I have to switch in AT mode but it’s unable to do it ! if I do the switch by myself and then reconnect Wistoolbox it displays all infos properly:


→ I’m now able too to create and edit a template without any problem.
→ Firmware part is still not working (the AppImage is missing some Pithon libraries needed for app to flash fw !

Let me know if you need additional tests or infos and impatient to test the next version of Wistoolbox when it’ll be avalaible :wink: In the meantime I’ll try to find a way to upgrade the device RUI version…

Hi @vincen ,

Thank you very much on your feedback. These are really valuable for us to improve our products and services.

If I understand correctly, the critical issue we have at the moment are:

  1. RAK3172 is not in AT mode (How did you put the RAK3172 in AT mode? By default it should be in AT).
  2. Python libraries missing to make template works.
  3. RAK ID still cannot be integrated.
  4. On AppImage, adding to dialout group is what needed to be done.

Can you please confirm? Or if I missed some points?