Wrong answer when setting NetworkMode

Hi!

I’m implemtening an API using the latest RUI3 firmware. So far everything works fine, but the command for setting the network mode gives no reply. According to the docs, the response should be “OK” or “AT_PARAM_ERROR”, but it seems the devices just reboots.
See the following transcript, i enabled command echos for clarity:

AT+VER=?
AT+VER=3.4.2-rui3_22q1_update.112
OK
AT+NWM=?
AT+NWM=0
OK
AT+NWM=1

RAKwireless RAK3172-E Example
------------------------------------------------------
Current Work Mode: LoRaWAN.

Rebooting the device should not be an issue, however, it should at least respond before that.

Thank you for the feedback @avathar .

We will update the docs and consider adding OK reply. I will coordinate with the SW team :+1: