AT+P2P=868000000:7:125:0:10:14 Commend not working

Hello sir

I am useing RAK3172 module. I will test LoRa P2P successfully via AT commands.

But after using RAK3172 as a Stand-Alone Device I am uploading the RAK3172 (.hex) file available at hex file
to configure the device in AT command mode.

But After uploading new firmware (AT+P2P=868000000:7:125:0:10:14) command gives the error. “AT_MODE_NO_SUPPORT”

can you give some suggestions on it?


I found my mistake but after setup, the module in P2P mode “AT+P2P=868000000:7:125:0:10:14” commend showing “AT_PARAM_ERROR”

I setup parameters according to this link

can you give some suggestions on it?

Hi @pragnesh ,

We have to update the guide since we add more bandwidth options (but numbered it differently).

You have to use 0 for 125 for the bandwidth setting. Thanks.

hi @carlrowan

Thanks for the replay.

Could you send me the updated guide?

So that I can update my Master’s code.

Hi @pragnesh ,

I already discussed this to the team and it will be backward compatible on the next release of the RUI3 firmware v3.5.4. Right now, the stable version is 3.5.3.

To be compatible on the new convention, you just need to update the 3rd parameter which is the bandwidth. On your test, you use 125. Therefore from

AT+P2P=868000000:7:125:0:10:14 it will become AT+P2P=868000000:7:0:0:10:14

You can see that 125 was changed to 0.

This follows the other possible bandwidth values:

0 = 125
1 = 250
2 = 500
3 = 7.8
4  = 10.4
5 = 15.63
6 = 20.83
7 = 31.25
8 = 41.67
9 = 62.5