Gateway RAK7243C minicom not response command "at"

Issue:In minicom it does not respond to the “at” command

Setup:RAK7243C

Server:TTN

Details: I am installing a “Gateway” RAK7243 (RAK2245, RAK2013, RPi 3B), but when configuring the LTE module and entering the command “sudo minicom -D / dev / ttyAMA0 -b 115200” I have no response to the command “at” . It would be helpful if someone has a solution.
Thanks

Dear Danny,

Please send the command to check the version:

gateway-version

Best regards!

Thanks for answering, I am attaching the version of the “Gateway”

Dear Danny,

Had you previously modified the Baud rate of LTE?

Best regards!

Dear Nicholas,
No, I have tried different ‘baudrate’ values but none seem to work.
He tried with these S.O. “RAK7243_LTE_based_on_Raspbian_OS_for_RPI3_V4.1.0_20191202.img”, “RAK7243_LTE_based_on_Raspbian_OS_V2.9.2_20190820.img”, “RAK7243.2Cbian200”.
I am using a SIMCard IoT Hologram and it is activated correctly.
The RAK2013 model is EG95-NA
I attach a picture of the problem


Best regards!

hello @dfguaman3


Can you connect only rpi and lte, not rak2245, and then see if the at command is normal?

Is the led light of LTE normal?

Dear ZhuQI,
Thanks for the recommendation, I managed to get a response from the ‘AT’ commands, configure the cellular carrier to access the Internet, I am using a HOLOGRAM IoT SIMCard and according to the page I am already connected. I proceeded to integrate the LoRa RAK2245 Concentrator but on the TTN page the Gateway does not appear connected.
I entered the command ‘systemctl status ttn-gateway -l’ to see the status of the TTN service and the command ‘systemctl status rak-pppd’ shows me the corresponding IP’s and DNS’s.
Blue LED = On
Green LED = On
Red LED = Blinking
I attach the images of the aforementioned




Very thankful

Dear Danny,
1.What caused RAK2013 to not respond to at?
2.What does the gateway use to access the internet? lte or wifi?
3.Have you configured the correct server ip and port? You can view them in the file /opt/ttn-gateway/packet_forwarder/lora_pkt_fwd/global_conf.json.
微信截图_20201014100833
4.If the server ip and port are configured correctly, please use the command tail -f /var/log/syslog | grep ttn-gateway to check whether the following print


5.If there is some ACK printing, it means that it has successfully connected to TTN.
6.If there is no ACK printing, please confirm whether you have used a network cable or wifi to connect your PC and gateway?If you use lte to access the internet, please disconnect the wifi and network cable.

Dear ZhuQl,
Thank you very much for the help, I already have access to the Internet through LTE integrating the RAK2245, before applying the steps you mention, I removed the resistors 153 and 154 as mentioned in this post.


Thanks again everyone for your support.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.