RAK4630 No ACK Knowledge


I’m working in a company which develop IoT with RAK4630 module.
The PCB and the embedded software have been developed by a subcontractor.
We want to get the software known within our company to design a new PCB / Firmware.

We want to upload a standard firmware as we want to explore programming the RAK.

As the PCB is industrial one, our situation is the following:

  • we do not have USB connector
  • the programming connector is a Tag-Connect
  • the firmware has replaced the bootloader.

I have access to RAKDAP1 and J-Link, but I was not able to upload the bootloader.

I’ve followed the tutorials using these links:

As we do not have the Tag-Connect cable, we have soldered 4 wires to the RAK4630 module (VCC, GND and both SWD wires).

Running pyOCD command based on RAKDAP1 quick start guide

  • pyocd erase -t nrf52840 --chip
  • pyocd flash -t nrf52840 RAK4631_latest_final.hex

We get the following error:

  • 0000881:CRITICAL:main:No ACK received

Any comment or help is more than welcome.

Welcome to the forum @ETM

A few things you can try/check:

  • Double check your wires and connections.
  • Make sure VCC is 3.3V and not 5V on the RAKDAP1
  • Add connection of RESET from RAKDAP1 to the RAK4630
  • Disconnect VCC on RAKDAP1 and power your PCB from external source. But make sure GND is still connected between RAKDAP1 and the RAK4630

Thank you for the propositions.
I’ve controlled all these points, and found a short circuit on SWDCK and 3V3.
I’ve modified another board and I finally managed to flash it:

I’m adding a USB connector so I may have other questions.


Re @beegee
I’ve uploaded the bootloader in version 0.4.3.

With the RAK powered, when I connect the USB, no serial com is detected by Windows 10.

When I trigger the reset then:

  • the serial port is detected,
  • the RAK4631 volume window shows up.

The INFO_UF2.txt contains:
UF2 Bootloader 0.4.3
Model: WisBlock RAK4631 Board
Board-ID: WisBlock-RAK4631-Board
Date: May 20 2023
Ver: 0.4.3
SoftDevice: S140 6.1.1

I’ve tried to upload a simple LedBlink arduino sketch but I’ve got an error “COM doe not respond”.

Below Error from Arduino IDE (2.1):
2023-06-22 15:36:35,420 Using board at serial port: COM8
2023-06-22 15:36:35,430 Sending Application image.
2023-06-22 15:36:39,020 No trigger interface found for device with serial number: 0ED88FD05D248637, Product ID: 0x0029 and Vendor ID: 0x239A

2023-06-22 15:36:39,020 Serial: Waiting 500 ms for device to enter bootloader 1/10 time

2023-06-22 15:36:43,612 Serial: Waiting 500 ms for device to enter bootloader 10/10 time
2023-06-22 15:36:44,124 Serial: Device is either not in bootloader mode, or using an unsupported bootloader.

So I tried to test AT commands using Termite software with the following COM parameters:

  • Baudrate 115200
  • Append LF
  • No flow Control

The RAK never responds.
Also tested on Termite 3.4 as shows the screen below

Before using Arduino, I think I need to solve AT commands communication.
My problem remind me of this recent ticket on the Forum.

Can you give me some advice and things to test?

About Termite, it doesn’t work for me on Win 10/11 at all, I am using CoolTerm.
You need to append CR & LF

AT commands work only if there is an application on the RAK4630. What you have flashed right now is the Arduino Bootloader version, that doesn’t support AT command without an additional application (e.g. based on my WisBlock-API-V2

If you want to use AT commands with a “blank” RAK4630, you have to use our RUI3 API, this has the full AT command set by default.
Here is the guide how to change from open source Arduino to RUI3 ==> Updating RAK4631 to RUI3

For the problem with flashing a firmware

(1) If you have the open source bootloader, you need to install the open source BSP for RAK4631 ==> Installation of Board Support Package in Arduino IDE

(2) If you have the RUI3 bootloader, you need to install the RUI3 BSP for RAK4631 ==> RUI3 Supported IDE

Good to know about Termite, I’ll try using CoolTerm.

As I couldn’t upload code via USB and Arduino IDE I tried to merge .hex files (bootloader+application) and flash them into RAK. It worked, but it seems that the ledBlink application doesn’t run (maybe stuck in the bootloader?).
Noted for the AT commands, I’ll upgrade the RAK to RUI3 and test AT commands at least.
I don’t understand why I see it on Serial Ports but I can’t communicate with it. Maybe be it is because of the state in which the RAK starts and waits for something.

About Arduino packages, I indeed downloaded and tried both of them in case of and still didn’t work.
Here is the bootloader I have actually: Bootloader 0.4.3

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.