Rak7204 can't connect to lorawan

Issue: device wont connect to lorawan, despite following the quickstartguide

Setup: Windows pc, Rak7204 connected via usb, lorawan gateway close by

Details: this is the concole output:

i have entered the correct device EUI and so on, i just replaced the values with xxx because i dont want to publish them here.

at+set_config=device:restart
LoRa ® is a registered trademark or service mark of Semtech Corporation or its affiliates. LoRaWAN ® is a licensed mark.

========================================================


| ___ / _ \ | | / / | | | () | |
| |
/ / /\ | |/ / | | | | _ __ | | ___ ___ ___
| /| _ || \ | |/| | | '
/ _ \ |/ _ / __/ __|
| |\ | | | || |\ \ \ /\ / | | | __/ | /_ _
_| __| |
/_| _/ / /||| _|_|_||//


RAK7204 Version:3.0.0.14.H.beta4


========================================================
UART1 work mode: RUI_UART_NORAMAL, BaundRate: 115200, N81
UART3 work mode: RUI_UART_USER, BaundRate: 115200, N81
BME680 init success.
autosend_interval: 600s
Current work_mode:LoRaWAN, join_mode:OTAA, MulticastEnable: false, Class: A
Initialization OK
OTAA Join Start…
[LoRa]:Join retry Cnt:1
[LoRa]:Join retry Cnt:2
[LoRa]:Join retry Cnt:3
[LoRa]:Join retry Cnt:4
[LoRa]:Join retry Cnt:5
[LoRa]:Join retry Cnt:6
ERROR: 99
OK Sleep

at+set_config=lora:app_eui:xxx
OK Wake Up
BME680 init success.
OK

at+set_config=lora:app_key:xxx
OK

at+set_config=lora:region:EU868
OK

at+set_config=lora:dev_eui:xxx
OK

at+join
[LoRa]:Join retry Cnt:1
[LoRa]:Join retry Cnt:2
[LoRa]:Join retry Cnt:3
[LoRa]:Join retry Cnt:4
[LoRa]:Join retry Cnt:5
[LoRa]:Join retry Cnt:6
ERROR: 99
OK Sleep

How far away is “nearby” and what is between the RAK7204 and the gateway and can you confirm the gateway is active.

Thanks for your fast reply.
I was right next to the University building the gateway is in. Howewer i cannot currently enter the building due to Corona.
I will contact the University to make sure the Gateway is online. Do you have any other ideas what the problem might be

What did you set as DR? Try changing that value. I have some that Error with DR=1 and Join with DR=3.

Hi, I have the same problem as @Basti. My test GW is right beside of RAK7204 (40cm or so), connected to my Chirpstack server. I can see Join requests on GW and also in Chirpstack app server but that is all. Also followed quick start guide, I have set all needed parameters, (it is usual/similar set up process that I did with different nodes from other manufactures, and it works without any problems, same test GW and same Chitpstack server) . I’m in EU region.

Attempts:

Chirpstack (only 3 attempts here … strange):

Any idea?

EDIT: just quick note, I have two RAK 7204, now I have made configuration ABP on second one and it seems that it works. I have this in my Chirpstack device data decoded:
2021-02-14 13_30_42-ChirpStack Application Server — Mozilla Firefox

EDIT 2: … conclusion(?): no OTAA on RAK7204

EDIT 3: … but finally, the second device in ABP mode sent payload only two times and stayed quiet

EDIT 4: I made unplug/plug of the device and again, it sends only two uplinks:


Is it connected with this problem?

Hi, I left both devices RAK7204 running (both set to ABP mode (OTAA didn’t work)) and it randomly sends up-links:

Hello Oskar,

What firmware is flashed on the both devices?

Hi @Martin,

it has V3.0.0.14.H.beta4

Regards,
Oskar

Hi @Martin , I have found(?) problem. It seems that RAK7204 doesn’t like other GWs then RAK2245 Pi HAT. I have assembled and got running GW based on RAK2245 Pi HAT and nodes RAK7204 started to join even in OTAA mode. Strange. They even send regularly data as expected (not got to the point of stopping to send data at all as described in “stops transmitting” post). One might to say problem solved but it seems that other GW might have problem with RAK7204, maybe it is the same problem that had @Amelia244.

That’s like shouting in someones ear with the consequent overload. Try putting them 5m apart or with a brick wall between.

I know, that was at the beginning, then I spread RAK7204 around the house and behind the wall, it doesn’t solved the problem. It seems that GW was the problem I think … will test it further with that GW when I have time.
As I wrote, it is strange, on non RAK GW I’m running other devices in OTAA mode w/o problem. What is funny, I have found out, that devices from Dragino also work correctly only with RAK GW :slight_smile:

Hi @Basti
I start using a RAK7204 for my project, does this need a special type of USB cable or it uses regular micro USB cable, and is the USB cable included in the box, because i did not received this cable.

Hei @Mary ,

Just a regular Micro USB cable will do, the box does not contain one.

Regards
Vladislav

1 Like

Hi @Oskariot @Basti
I have the same problem with my RAK7204, have you found a solution for joining with OTAA ? my gateway is Kerlink wirnet ifemtocell-evolution, and RAK7204 cannot join.
should I create a new application in TTN to use ABP for this device to join?
Thank you very much if someone could help me in this regard.

What does your gateway console on TTN show - is it hearing the join request, is it sending a join accept?

Which TTN version did you end up using?

1 Like

Hi @Mary, sorry, I don’t use TTN server, I have private ChirpStack cloud server. I’m still running RAK7204 in OTAA mode with RAK GW without any problem. I didn’t have time to retest it with different GW. I hope that during this weekend I’ll give it another try.
Regards.

Hi all,
just update regarding my retest RAK7204 with second GW (in my case Mikrotik). I have stopped RAK GW. One device Rak7204 has connected to the Mikrotikk GW second one several hours sent Join requests and from GW was send join accept but that was all, several join requests and join accepts. After a while first RAK7204 stopped send data regularly (it should send data every 15 min). Delay occurs randomly (30min or one hour).
So the behavior is the same as at the beginning (some time ago).

Hi @nmcc
Thank you very much for your reply, you right the status of my gateway in console is “not connected” as the picture below, but I do not know what the problem could be to fix that. I would greatly appreciate if someone could advise me in this regard. my gateway is Kerlink “Wirnet iFemtoCell-evolution”. I added gateway EUI as it is written under the gateway and also with the command cat /var/run/lora/gateway-id.toml.
before configuration I had done factory reset twice, is it possible that this made it changed?
I am using V2

As this is the RAK forum and not the Kerlink forum, perhaps you should post this issue on the TTN forum?

At least there will be Kerlink users there …

Yes thank you very much for your advise. I will do that.