RPi + RAK2013 Not Connecting

I am trying to connect a RAK2013 to a Raspberry Pi 3B+ and connect to the internet.

I have tried using the RAK2013 via the Raspberry Pi Connector only, with a fresh install of Raspbian Stretch and follow instructions in the following post:
https://forum.rakwireless.com/t/raspian-not-detecting-rak2013-cellular-wislink-raspberry-pi-hat-bg96-4g-lte-cat-m1/307/7

AT in Minicom responds with OK, but I am unable to connect to the internet through the RAK2013.

I have also tried using the RAK Image specified in this post:
https://forum.rakwireless.com/t/im-not-able-access-internet-through-rak2013-with-rpi/160/2

But sudo minicom -D /dev/ttyAMA0 -b 115200 does not read in any keyboard input.
Any help would be appreciated.

Please have a look at the section 6.4 of the following document:
http://docs.rakwireless.com/en/LoRa/Pilot-Gateway-Pro-RAK7243/Application-Notes/Get_Start_with_RAK7243_with_LTE_LoRa_Gateway.pdf

BTW, if you can not see any keyboard input in minicom, just do as follow:

Is there any way to have the RAK2013 module working without using the RAK OS?

Also when echo is turned on in minicom, I can type into the console, but there is no response at all.

If you want to use RAK pre-compiled firmware image directly, there is the source code on Github, and you can use the source code to install manually by yourself.

Hi @jack
Please try this RAK2013 PiHat .
It is tested and run fine for me.

Regads
Todor

Hi @velev I have already tried running that before.

It allows the RAK2013 module to turn on with all 3 LED’s showing, but it does not provide any cellular connectivity.

I have a clean install of Raspian Stretch updated to the latest version. Would I be required to install anything else to have internet connectivity through the RAK2013?

Does the USB have to be connected as well?

I have cloned and installed the repo onto the latest clean version of Raspbian, but when I run minicom command "sudo minicom -D /dev/ttyAMA0 -b 115200” there are no inputs or response on the terminal, even after turning echo on for minicom, any AT commands I enter don’t return anything.

Hi @jack

Maybe you need to install minicom tool firstly.
You can use RAK github project for RAK7243 with LTE to install on your pure Rasobian Stretch OS, and it will install minicom automatically:

Hi @Fomi

I already have the minicom tool installed.
I will try using the github project and see if it gets me any further.

Please also kindly check your messages as I have sent you one.

Kind Regards

1.Download this file “https://github.com/RAKWireless/rak_docker_for_gateway/blob/master/rak/rak/bin/active_lte_module.sh” in your new system and run the script “sudo ./active_lte_module.sh”, which activates the LTE module.
2.Then, run minicom again and see if the at command has responded.

Hi @ZhuQI

I have downloaded and run the script, but I get the following error

sh: echo: I/O error
sh: echo: I/O error
sh: echo: I/O error
sh: echo: I/O error
sh: echo: I/O error
sh: echo: I/O error
sh: echo: I/O error

Any ideas what the issue could be? The GPIO outputs match the script values and if I manually change the value of GPIO 18 I can manually reboot the module, but the minicom commands still does not return any values when accessed, even after turning on echo.rak2013 minicom

Kind Regards

Sorry, it is my negligence.
In new OS:
1.Add a line “dtoverlay=pi3-disable-bt” to the end of the file /boot/config.txt
2.run “sudo systemctl disable hciuart”
3 run “systemctl disable [email protected]
4.reboot ,then execute the “sudo ./active_lte_module.sh” command, Are all three LED lights on?